I'm working on the pop-up editor. so far so good, but there is an small issue, that i dont know how to fix it.

my pop-up editor works properly. But sometimes it doesn't, sometimes it takes up the whole screen instead of just a pop-up editor (attached images bellow)


thank you!


Solution

Hi Minh,

That kind of behavior usually it's due to the fact that the link lost his reference to the popup editor widget.

At some point in your logic you are refreshing the link and not the popup editor widget or vice-versa. Am I right?

Solution

Nuno Rolo wrote:

Hi Minh,

That kind of behavior usually it's due to the fact that the link lost his reference to the popup editor widget.

At some point in your logic you are refreshing the link and not the popup editor widget or vice-versa. Am I right?

i haven't found out where is the problem yet, but you mean I must refresh the pop-up editor and the button the at same time?   


Hi 

Please  check web block you set for the popup screen layout from the widget tree,where you set it as  below or not.

Another way , debug for both conditions .


Happy Wednesday!


Layouts\LayoutPopup


Nuno Rolo wrote:

Hi Minh,

That kind of behavior usually it's due to the fact that the link lost his reference to the popup editor widget.

At some point in your logic you are refreshing the link and not the popup editor widget or vice-versa. Am I right?

Ohh well, i have tried to refresh the button and the Pop_up_editor with the Ajax refresh at the same time in the action screen and it actually worked. thank you a lot sir! 


I Mon (EiMon) wrote:

Hi 

Please  check web block you set for the popup screen layout from the widget tree,where you set it as  below or not.

Another way , debug for both conditions .


Happy Wednesday!


Layouts\LayoutPopup


My problem is solved, but thank you anw. have a nice day.