Input AutoComplete problem

Input AutoComplete problem


I'm using the latest version of Rich Widgets and I'm having a problem with the Input AutoComplete.
I have an Edit Record with several fields and one of them uses the AutoComplete.

Steps to reproduce the problem:

- Enter the page with the Edit Record
- Double-click the input that's using the AutoComplete
- Choose one of the options from the dropdown list
- Try to save the record

Error -> The "Input_Autocomplete_GetIndentifier" returns "-1".

This problem doesn't happen if I write something on the input and then choose from the dropdown list.

Has anyone had this problem?


I just tried this using the latest StyleGuide (4.2.10) Template sample. In the Customers page, I clicked one of the customers, pressed "Edit" (which takes us to an edit record), double clicked on the Country input and selected one of the countries there and pressed Save. It worked fine.

I also created a "New Customer" and selecting from the country list without typing anything in also worked well.

The problem you're having may well be specific to your application. Please consider submitting the issue to OutSystems Support and provide them with the specific eSpaces that are causing this if you haven't found out what's wrong yet.


You're right Miguel. After much debugging I finally saw the error. Thanks anyway.