Boostrap data using Excel File



Hi, I have one Static entity and one Excel File. When I boostrap data for Communication Entity and setup logic for boostrap. I have a problem that when data boostrap, the attribute CommunicationTypeId just get "Last News" data for all records.



This is my logic to get the right CommunicaitonTypeId for Communication Entity. After Switch check I assign right Type for each record. But all record like this 

From beginning, after fetch data is look like above, after I set logic to boostrap, It still not change.

Dat Bui wrote:



Hi, I have one Static entity and one Excel File. When I boostrap data for Communication Entity and setup logic for boostrap. I have a problem that when data boostrap, the attribute CommunicationTypeId just get "Last News" data for all records.



This is my logic to get the right CommunicaitonTypeId for Communication Entity. After Switch check I assign right Type for each record. But all record like this 

From beginning, after fetch data is look like above, after I set logic to boostrap, It still not change.

Hi Dat Bui

can you send the oml. file for better understanding.



Hi ,

Generally while bootstrapping, did you get the ID field getting mapped in the confirmation message before bootstrap. 


Thanks and Regards,

Priya 


Hi dat,

Seems like conditions are not satisfied and therefore it always goes to otherwise branch.

Try to compare with hardcoded ("Latest News") value rather than GetCommuniactionType.....CommunicationType.label

or ConvertFromExcel..... = GetCommuniactionType.......CommunicationType.Id

Hope it helps

Regards

Seema


Hi Dat,

Have you added CommunicationTypeLabel attribute manually to the structure created by bootstrap? Because service studio usually ignores non matching columns.

If this is the case then you have to make sure that this column is on same position (first in your case) on which it is in the excel file. Otherwise it will always have some wrong or blank values.

Poonam Verma wrote:

Dat Bui wrote:



Hi, I have one Static entity and one Excel File. When I boostrap data for Communication Entity and setup logic for boostrap. I have a problem that when data boostrap, the attribute CommunicationTypeId just get "Last News" data for all records.



This is my logic to get the right CommunicaitonTypeId for Communication Entity. After Switch check I assign right Type for each record. But all record like this 

From beginning, after fetch data is look like above, after I set logic to boostrap, It still not change.

Hi Dat Bui

can you send the oml. file for better understanding.



Here you are,


Nikhil Gaur wrote:

Hi Dat,

Have you added CommunicationTypeLabel attribute manually to the structure created by bootstrap? Because service studio usually ignores non matching columns.

If this is the case then you have to make sure that this column is on same position (first in your case) on which it is in the excel file. Otherwise it will always have some wrong or blank values.


Yes, this is a difference in this case. column name in excel is CommunicationTypeLabel, but the attribute is CommunicationTypeId. So when I bootstrap data from excel I set logic to convert data in Switch widget. But It goes wrong in Reactive Web, about Traditional it work success!

Difference between excel column name and entity attribute name is fine but what I am asking is during bootstrap a new structure is created. This structure has all the attributes which are imported from excel. So please check if in that structure you have your CommunicationTypeLabel attribute on first position (because this is the first column in your excel)

If attribure position is different in structure and excel then this will not work in reactive and treditional both.

Dat Bui wrote:



Hi, I have one Static entity and one Excel File. When I boostrap data for Communication Entity and setup logic for boostrap. I have a problem that when data boostrap, the attribute CommunicationTypeId just get "Last News" data for all records.



This is my logic to get the right CommunicaitonTypeId for Communication Entity. After Switch check I assign right Type for each record. But all record like this 

From beginning, after fetch data is look like above, after I set logic to boostrap, It still not change.



Dat Bui wrote:

Poonam Verma wrote:

Dat Bui wrote:



Hi, I have one Static entity and one Excel File. When I boostrap data for Communication Entity and setup logic for boostrap. I have a problem that when data boostrap, the attribute CommunicationTypeId just get "Last News" data for all records.



This is my logic to get the right CommunicaitonTypeId for Communication Entity. After Switch check I assign right Type for each record. But all record like this 

From beginning, after fetch data is look like above, after I set logic to boostrap, It still not change.

Hi Dat Bui

can you send the oml. file for better understanding.



Here you are,


This solution is worknig perfactly fine at my end. All the data imported is just fine, see screenshot below.

Nikhil Gaur wrote:

Dat Bui wrote:

Poonam Verma wrote:

Dat Bui wrote:



Hi, I have one Static entity and one Excel File. When I boostrap data for Communication Entity and setup logic for boostrap. I have a problem that when data boostrap, the attribute CommunicationTypeId just get "Last News" data for all records.



This is my logic to get the right CommunicaitonTypeId for Communication Entity. After Switch check I assign right Type for each record. But all record like this 

From beginning, after fetch data is look like above, after I set logic to boostrap, It still not change.

Hi Dat Bui

can you send the oml. file for better understanding.



Here you are,


This solution is worknig perfactly fine at my end. All the data imported is just fine, see screenshot below.

Yes, thank you I will check this.


Dhivya prabaa wrote:

Dat Bui wrote:



Hi, I have one Static entity and one Excel File. When I boostrap data for Communication Entity and setup logic for boostrap. I have a problem that when data boostrap, the attribute CommunicationTypeId just get "Last News" data for all records.



This is my logic to get the right CommunicaitonTypeId for Communication Entity. After Switch check I assign right Type for each record. But all record like this 

From beginning, after fetch data is look like above, after I set logic to boostrap, It still not change.




Thank you!!