Application cannot be safely installed in your environment

Hi all

For the past couple of months, I've noticed that Studio will say I need to update both OutSystems UI Templates Mobile and Outsystems UI, however, If I try to update Outsystems UI, it will say that I can't safely do so because it's not compatible with the currently installed UI Templates Mobile (and I should update that one first). If I then try to update the UI Templates Mobile, it will say that I can't because it's not compatible with the currently installed OutSystems UI.

I'm assuming that if the documentation on UI Templates Mobile states that it is compatible with the latest OutSystems UI (which I have not installed yet), I just have to ignore the warnings and update OutSystems UI first, but then directly update the UI Templates Mobile after that so that it will be compatible again?



Solution

Hello Pieter,

I would install first OutSystems UI, as its a dependency of the OutSystems UI Templates Mobile, and then the other.

I think this message will always happen (or almost always) because both are updated in Forge, but you can't update both at the same time.

Cheers.

Solution