how to make screen have theme ?

I've created a theme then I created the application based on this theme, The theme appears in common\Layout but when I create Mainflow then Webscreen the screen is empty and it doesn't contain the theme elements.

How can I make the screens have this theme ?

Hi Muhamed,

You can specify a Theme at Module level, and at Screen Flow level:


Kilian Hekhuis wrote:

Hi Muhamed,

You can specify a Theme at Module level, and at Screen Flow level:


Hello Kilian,

I've referenced the theme and even after applying th theme in module level and in ui flow level it isn't applied to the screen ,

Do I have to reference the theme or choosing it while creating the application is enough ?

Thank you

You can reference another theme if you want or just use the default one. Note that layouts is applied to screens you will create later and not applied to the existing ones (you will need to edit them manually).


Regards,

JC

Juan Carlos Elorde wrote:

You can reference another theme if you want or just use the default one. Note that layouts is applied to screens you will create later and not applied to the existing ones (you will need to edit them manually).


Regards,

JC


I've applied the theme while creating the application ,I've referenced the theme too 

but the theme is not applied.

Thank you

Hi,


Did you already verify if layout used in your pages are the correct ones (from your theme)?


Hope this can help.


Best regards,

Ricardo

Ricardo Pereira wrote:

Hi,


Did you already verify if layout used in your pages are the correct ones (from your theme)?


Hope this can help.


Best regards,

Ricardo


yes, but the correct layout appears in basic layout not in common

when i create the application I've choosen to be from my pre created template

Is it supposed that the screens should have the same layout in the template ?

If yes ,why it isn't ?

Hi Muhamed,


Can you share with us your OML? It's better to understand your problem.


Best regards,

Ricardo

Ricardo Pereira wrote:

Hi Muhamed,


Can you share with us your OML? It's better to understand your problem.


Best regards,

Ricardo

Sorry I won't be able to share with you the oml because it's not in personal environment ,

I was confused between the template and the theme ,Here's steps of what was done to understand the porblem well

1. I have a template ,when i open the layout of this template i find the layout of the screens i want.

2. I've created a web app based on this template (whle creating i choose that template).

3.when i open the web app i find the correct layout inside basic_layouts tab not in the common ui flow.

4. when i create a new UI flow (Mainflow) and create a screen in it  the screen is blank and doesn't contain anything from tha layout.

Thank you.


Did you expose (make public) the elements of that layout and consumed it in your application?

Happened to me as well when the menu of a layout is not public. So when I created a screen based on the layout, it doesn't have the menu.

yes it's public, when i drag and drop the layout to the screen it is applied correctly,

is there a way to make any created screen in my application have this layout without applying this manually ?

I've selected it as the module base theme,and the UI flo also.