Can't run outsystems .net framework not suported

Hello,


My name is phil. I am trying to run outsystems on my home pc but I am unable. When I try to run it, it says it requires .net framework version 4.7.2 but when I try to install it it says it is not suported. Anything I can do to fix it?

I am using:

Windows 10

Outsystems 11

Hi,

Please, install version 4.8 instead: https://dotnet.microsoft.com/download/dotnet-framework/net48

If you have any problem with installing the framework, you may need to talk to Microsoft Support. 

Cheers.

Eduardo Jauch wrote:

Hi,

Please, install version 4.8 instead: https://dotnet.microsoft.com/download/dotnet-framework/net48

If you have any problem with installing the framework, you may need to talk to Microsoft Support. 

Cheers.

Thanks for the reply!


I get the same incompatible message when I try version 4.8.


Anything above the one I currently have installed (4.6.2) yelds the same result.


Anything else I can try?


Just so you know I also tried uninstalling Outsystems and installing it again. Also would have my .net framework but unfourtunately I don't know how.


Solution

Your Windows may need some kind of "upgrade", I would say.
You should see if there are updates to be done.

What's the message you receive when tries to install the Framework?

Solution

I have the same problem. Yesterday, when I ran the Service Studio 11 it worked, but today it doesn't work. It gives the same error. That the application requires version 4.72 of .NET Framework.


When I try to install that version of .NET Framework , or any other like the latest 4.8, it gives the error that says that it is not supported on this Operating System.


I don't see any windows updates installed lately.


Windows 10


What could be the problem and how we can fix it?

Luis Nieves wrote:

I have the same problem. Yesterday, when I ran the Service Studio 11 it worked, but today it doesn't work. It gives the same error. That the application requires version 4.72 of .NET Framework.


When I try to install that version of .NET Framework , or any other like the latest 4.8, it gives the error that says that it is not supported on this Operating System.


I don't see any windows updates installed lately.


Windows 10


What could be the problem and how we can fix it?


I solved it by going on setting>Update and security>windows updates.


There I had some updates that hadn't installed for whatever reason. So I clicked the retry button and it worked. Hope this helps!


Cheers