How to reinstall agile platform 4.2 after uninstall agile platform 5.0?

How to reinstall agile platform 4.2 after uninstall agile platform 5.0?

  
Hi
I need some help with the following problem:
->I want to install agile platform 4.2 after uninstall agile platform 5.0 but I have a message saying that I have a “more recent version”.
->Unfortunately I install agile platform 5.0 before read “Side Effects and Breaking Changes in Version 5.0.pdf” and I don’t have enough knowledge to make the necessary change in extensions, for publish in Integration Studio (Ex.: RSS.xif).

Regards,
Tiago Vicente

Hi Tiago

 

The Agile Platform Community Edition 4.2 is probably trying to reuse the same database catalog previously used by the Agile Platform Community Edition 5.0. This is the expected behavior, however, the Agile Platform in general doesn't allow the downgrade of the OutSystems databse catalog, due to possible data and metadata inconsistencies.

 

So, you have 2 choices:

 

  1. Install the Agile Platform 4.2 with a new database catalog, by deleting/renaming the existent one.This will effectively make you loose the applications and data published with 5.0. If you had a database backup from before the 5.0 upgrade, it would solve this problem.
  2. You work towards fixing the breaking changes in the extensions, which is the best choice.

I suggest you identify which extensions are not being upgraded, possibly due to the breaking changes, and post them here. We will give you a hand in upgrading them. :)

 

Cheers

 

Miguel Simões João