Hi all,


I am trying to build my application on iphone platform.

I get the following error while building the ipa.

can anyone help me on this?

In iOS on 2020-02-03 at 15:45:43 - Generation failed due to plugin version incompatibility with MABS. We recommend that you review the following plugin(s) and retry building the app:

OneSignal-Cordova-SDK version 2.3.2-OS2 must be equal or greater than 2.6.0-OS1


Also what i got from error description, that i need to upgrade OneSignal plugin,

So how to do that?

Thanks,

Dhiraj M

Hello Dhiraj,

Where is this plugin coming from?
Did you implemented it or did you fetched it from Forge? I think there is a plugin for OneSignal already in the Forge, no?

Cheers.

Dhiraj Manwani wrote:

Hi all,


I am trying to build my application on iphone platform.

I get the following error while building the ipa.

can anyone help me on this?

In iOS on 2020-02-03 at 15:45:43 - Generation failed due to plugin version incompatibility with MABS. We recommend that you review the following plugin(s) and retry building the app:

OneSignal-Cordova-SDK version 2.3.2-OS2 must be equal or greater than 2.6.0-OS1


Also what i got from error description, that i need to upgrade OneSignal plugin,

So how to do that?

Thanks,

Dhiraj M

I'm having the same problem. Would be nice if someone guide us in the right direction.

Did you manage it to solve?


Be sure to post this in the support section of your used component. That way the authors get an email of your post and your more likely to get useful support.