So I've created a Modal with all of the following content within it. I've gotten to the point to where I've linked the trigger widget to it. The only obstacle now is even when clicking this widget nothing happens. I'm guessing it's some where within the screen action's flow that I have to affect it but I'm not even sure where to start. 

Jaret Sanchez wrote:

So I've created a Modal with all of the following content within it. I've gotten to the point to where I've linked the trigger widget to it. The only obstacle now is even when clicking this widget nothing happens. I'm guessing it's some where within the screen action's flow that I have to affect it but I'm not even sure where to start. 

These may be useful as well


Jaret Sanchez wrote:

Jaret Sanchez wrote:

So I've created a Modal with all of the following content within it. I've gotten to the point to where I've linked the trigger widget to it. The only obstacle now is even when clicking this widget nothing happens. I'm guessing it's some where within the screen action's flow that I have to affect it but I'm not even sure where to start. 

These may be useful as well




Solution

Hi Jared,

This post can be useful, look the step 1 of the the solution answer.


https://www.outsystems.com/forums/discussion/46421/how-to-create-a-modal-for-web-screen/

regards,

James

Solution

Make sure you are using Ajax Submit on your button or link

Hi Jaret,

You have to do following things

  1. Set a name on your model (so that you can find its id in toggle model)
  2. Set you button Method property to ajax submit
  3. On button action you already have toggle model so set your model id in it

Using these steps it should work. Please also find the sample oml for your reference.