How to trigger a mail using application data as a body in outsystems?

How to trigger a mail using application data as a body in outsystems?

Can you give more details than you want, so that it is possible to help you? What do you intend to do? What is the use case?

Are you already developing in Mobile, Web Traditional or Reactive Web?

Cheers

Swetha bhavani Gutthula wrote:

How to trigger a mail using application data as a body in outsystems?

Hi Swetha,


Can you please elaborate more.


Did you check the document on email functionality?


Thanks


Hi,

I am creating a form,  where i will enter some of the details and after clicking on submit button, it should  send/trigger a mail using the form details to the particular mentioned recipient

And you already have the service center configured to send emails? Configure OutSystems to Send Emails

Please, did you look to this document: Send an Email From a Web Application

Cheers

Yes, you can. all I'll suggest you please first understand the email functionality in OutSystems.Please refer below URL,

https://success.outsystems.com/Documentation/11/Developing_an_Application/Implement_Application_Logic/Send_an_Email_From_a_Web_Application

Swetha bhavani Gutthula wrote:

Hi,

I am creating a form,  where i will enter some of the details and after clicking on submit button, it should  send/trigger a mail using the form details to the particular mentioned recipient

Hi Swetha,

In your button click event you can prepare your email content (using the variable you have set in your form) in a local screen variable of text type and then pass that email content to the email action.


Swetha bhavani Gutthula wrote:

Hi,

I am creating a form,  where i will enter some of the details and after clicking on submit button, it should  send/trigger a mail using the form details to the particular mentioned recipient


Hi Swetha,


Can you please share which type of application you are using like Mobile, Web(Reactieve or traditional application)?


Apart then, There are multiple forge component for send mail. you can use anyone as per your requirement.  

Jitender Gaur wrote:

Swetha bhavani Gutthula wrote:

Hi,

Its Reactive Web Application.


Hi Swetha,


Can you please share which type of application you are using like Mobile, Web(Reactieve or traditional application)?


Apart then, There are multiple forge component for send mail. you can use anyone as per your requirement.  



Hi,

I have created a form in Reactive Web Application, where i will enter all the details and click on submit button, In submit button properties, in the event of Onclick have added a client action to send a mail. In the client action i have used EmailSend server action but its not working. 

What's wrong with this logic? 

Swetha bhavani Gutthula wrote:

Hi,

I have created a form in Reactive Web Application, where i will enter all the details and click on submit button, In submit button properties, in the event of Onclick have added a client action to send a mail. In the client action i have used EmailSend server action but its not working. 

What's wrong with this logic? 

Hello Swetha, 

If possible, Can you please share your .oml file or your client action screen-shot so that we can help to identify the issue. 

You can use this forge component to send mail. it will also help you to identify the issue.   

 


Hi Jitender,

Below is the attachment of the Client Action Screen shot.

Hi Jitender,

Below is the attachment of the .Oml file.

Hi Swetha,

Have you checked service center, any error logged or not.

if not please check and let us know.


Regards

Rahul Sahu

Swetha bhavani Gutthula wrote:

Hi Jitender,

Below is the attachment of the .Oml file.

Hi Swetha,


Thanks for sharing oml file. I have checked shared file and it is working fine on my environment. I have just setup email configuration in my service center and it is working without changes. Please see the screen shot to setup email configuration.


Please check you email configuration setting first.if it is already done then check your configuration is allowing to send mail.  

Hi,

Below is the attachment of the Email Configuration Screen shot.

Hi Jitender,

Below is the attachment of the Client Action Screenshot.

Hi Jitender,

Below is the attachment of the Send Email Configuration Screen shot.

Hi,

Please check the Email Configuration Screenshot and tell me if they have any corrections.

Swetha bhavani Gutthula wrote:

Hi,

Please check the Email Configuration Screenshot and tell me if they have any corrections.


Hello Swetha, 


I have checked email configuration detail shared by you and i think there are some issue with your username and password . When i was checking these feature with your shared details it's giving issue "Username and Password not accepted.". 


Please check again email details is it correct or not. because i have check Outsystems application and there are not any issue. It is working fine with email details.  

Hi,


Can i get the screen recorded video of doing email configuration?

Swetha bhavani Gutthula wrote:

Hi,


Can i get the screen recorded video of doing email configuration?

Hi Swetha, 


I have only configure correct email details in service center as i have shared screen-shot above. I didn't make any changes in Outsystems application. I have used application code same as you have shared.  


Have you checked which email details you are using that is correct. Apart then you can check below link for more details about enable application to access gmail account. This link will help you 



Swetha bhavani Gutthula wrote:

Hi,


Can i get the screen recorded video of doing email configuration?


You can also verify the setting for "Turn On Access For Less Secure Apps" in gmail account. 

Hi,

I am using the trial version of Outsystems, does it effect the email configuration?

Hi, 

I am not sure about it, but i think it should not impact the email feature.  

Hi,

After saving the email configuration details .i am getting this warning ,can u please tell about below attach screenshot 

Hi,

Please have a look on the screenshot attached.

Hi Swetha,

In order to apply your new email configuration you should create and publish a solution containing all modules.

Check the link to see how it’s done.

Regards,

Nordin

Hi,

Can i get the information related to the below screenshot?

Swetha bhavani Gutthula wrote:

Hi,

Can i get the information related to the below screenshot?


Hi Swetha, 


Are you using same email credentials which you are using previously. I was facing same issue with same email credentials shared by you. 


Can you please check with other one because same application working fine at my side.    

Jitender Gaur wrote:

Swetha bhavani Gutthula wrote:

Hi,

Even after changing the username and password i am facing the same issue.


Hi Swetha, 


Are you using same email credentials which you are using previously. I was facing same issue with same email credentials shared by you. 


Can you please check with other one because same application working fine at my side.    



Hi,

Even after changing the username and password i am facing the same issue.