UsersLocalManagement Module throws an error

I recently encountered an error when I used a dependency (an action) from UsersLocalManagement called "Group_AddRole". The error in Service Center is as seen from the image below.

Any help regarding this is very much appreciated.


Cheers,
Terence Daquiz

Terence Aaron Daquiz wrote:

I recently encountered an error when I used a dependency (an action) from UsersLocalManagement called "Group_AddRole". The error in Service Center is as seen from the image below.

Any help regarding this is very much appreciated.


Cheers,
Terence Daquiz

HI Terence,

Can you please share your usecase how you are using this action and when you get the error in your flow.


Nikhil Gaur wrote:

Terence Aaron Daquiz wrote:

I recently encountered an error when I used a dependency (an action) from UsersLocalManagement called "Group_AddRole". The error in Service Center is as seen from the image below.

Any help regarding this is very much appreciated.


Cheers,
Terence Daquiz

HI Terence,

Can you please share your usecase how you are using this action and when you get the error in your flow.


Hello Nikhil,

Basically, I used an editable table widget with the attributes of groupId and roleId as shown in the image below. On the "On Row Save" event action, I used the group_addRole server action from the UsersLocalManagement module and passed the selected groupId and roleId as parameters.

When executing the flow, however, upon saving the row, the error occurs.