[InAppBrowser Plugin] Cannot generate Android app due to Cordova plugin version

Forge Component
(10)
Published on 9 Jan by OutSystems R&D
10 votes
Published on 9 Jan by OutSystems R&D

I'm getting the following error when trying to build the APK:

Generation failed due to plugin version incompatibility with MABS. We recommend that you review the following plugin(s) and retry building the app:

cordova-plugin-inappbrowser version 1.7.0-os must be equal or greater than 3.1.0-OS2

I'm using the latest version of the plugin from the forge.

Any ideas?

Roy


Hello Roy, 

The latest version deployed of this plugin it is the version 3.1.0-OS3. 

You can check this in the extensibility configurations of the plugin. Can you give a look?

Because like that you hsould not have this error. 


Thanks, 

Camila

Turns out someone had mistakenly made a "non-edit" and it was seen as a custom version. I have deleted and re-installed the module and we're back up to date.

Roy Corneloues wrote:

I'm getting the following error when trying to build the APK:

Generation failed due to plugin version incompatibility with MABS. We recommend that you review the following plugin(s) and retry building the app:

cordova-plugin-inappbrowser version 1.7.0-os must be equal or greater than 3.1.0-OS2

I'm using the latest version of the plugin from the forge.

Any ideas?

Roy



Hi Roy, there was an update on GitHub of this plugin, you must access the Extensibility Configurations insert the following:

  • {
        "plugin": {
            "url": "https://github.com/OutSystems/cordova-plugin-inappbrowser.git#3.1.0-OS3"
        }
    }

And use the new version that is in the repository, republish your application and generate new packages (APK or IPA), let me know if it worked, ok?



Thankful
Murilo Antonio