Error: application sandbox location is not accessible

Error: application sandbox location is not accessible

  
Hello,

I had the community edition 4.2 installed. When 5.0 was released, I installed it with no problems.
Then I installed the upgrade for service studio 5.0.1.5 and I started having problems.
Whem I launch service studio, I get and error with the title "Xenocode Postbuild 2009" and with the message "The application sandbox location \DEVICE\HARDDISKVOLUME2\ProgramData\Application Data\OutSystems\Service Studio\5.0.1.5" is not accessible (attached). Please check the location and try again.

I already uninstalled everything, deleted the OutSystems regkey entry and the directory in Program Files and installed the community edition 5.0.1.5 but still I get the same error.

Integration studio starts with no problems.

Thank you,
Carlos Paredes
Hi,

Did you have any troubles installing 5.0.1.5? The installer finished with success?
I recommend you to run the installer again.
If this doesn't help, please contact the support. I'm sure they will help you on that.
Hi,

When I install I get the same error, but the installer continues as if nothing happened.
I sent an e-mail to support.
Cheers,
Carlos

Same problem here :(

Was there a fix to your problem?

Hans

Hi Hans,

Yes, I was missing the "Application Data" folder inside the "ProgramData" folder.

In truth, I wasn't  missing it, it was there and it was a shortcut that didn't point anywhere... and I had to take ownership of the object to find out about that because at first I didn't even have access to it (and I'm an administrator).
I have no clue how it got there in the first place...

So, in a nutshell:
- Make sure you're an administrator of the machine;
- Go into the ProgramData folder;
- Make sure the "Application Data" is a folder and you have access to it and can create folders inside; if you have a shortcut with denied access, take ownership and delete it before creating the "Application Data" folder;

Service Studio should work fine after that.

Good luck,
Carlos


No program data folder here :( I'm administrator on this system, but it's a sort-of managed system. (Ooh, the fun of Powerfuse)

Strange, the first 5.0 version worked without problems...

Try creating it yourself: \ProgramData\Application Data

No space between Program and Data, one space between Application and Data... or whatever you see in the error message. Service Studio dosen't seem to create those two folders, only the other folders inside "Application Data".
My error showed "VOLUME2" in the error message but it was going for drive C:
I had no problems with the previous versions either...

Cheers,
Carlos
Hi,

Service Studio 5.0.1.11 already fixes this problem. You can find it here:
http://www.outsystems.com/community/download.aspx?DocumentId=290

Regards,
João Neves

Hi,

I'm sorry but 5.0.1.11 still doesn't fix the problem. The problem will be fixed soon. In the meanwhile, as a workaround, you can create a batch file to launch Service Studio:

set allusersprofile=%temp%
cd %PROGRAMFILES%\OutSystems\Service Studio 5.0\
start ServiceStudio.exe

Regards,
João Neves