Yet another question about Processes 

Yet another question about Processes 

  
Hello all,

I have a proccess which can only be accessed by users with the "Approve" privilige. I'm doing the login in the enterprise, and almost everytime i have have an action in the task box, i click the link and i go to the destination, the problem is 80% of times it gives an error:

"Approve permission required" (seen in service center)  and resend me to login page, after i do the login again i'm at the destination webpage without an error.

Any clue what i'm doing wrong ?
Hi Miguel,

Could it be that you are logging in your application while executing a Run or an Open In Browser? If so, this means that you are logging in your Personal Area and the Task Box then directs you to the Public Area of your application.

If this is true, the following might be happening:
- You are logging in your application in your Personal Area (http://ServerName/eSpaceName/UserName/EntryPoint.aspx)
- You click on your task box and it points to the Public Area (http://ServerName/eSpaceName/EntryPoint.aspx)
- This gives you a Security Exception (because you did not login in the Public Area yet). You are redirected to the login page in the Public Area.
- You login in the application in the Public Area
- You are redirected to you task screen in successfuly access it in the Public Area 

To know more about this se the Personal Area page in Service Studio Help and the Public Area page in Service Studio Help.

To avoid the problem, access the application directly in the Public Area from start (without your username in the URL).

Was this your problem?

Best Regards,
Daniel Lourenço
Sorry for the late reply, i've been busy with another project.


"You are logging in your application in your Personal Area (http://ServerName/eSpaceName/UserName/EntryPoint.aspx)
- You click on your task box and it points to the Public Area (http://ServerName/eSpaceName/EntryPoint.aspx)"

It seems you're right. I'll look at it as soon as possible.

Thanks for the help, again.