OutSystems jumping when an element has been pasted and other broken stuff

Hi am literally losing my mind!!
I cannot deal with your constant screen jumping everywhere when I copy and paste an element.
Every time I paste a new element or action or anything 

"logic orientated"

every time I paste it. OutSystems will paste it on the other side of the planet...

For what reason I do not know why you guys would build something like this. I am assuming it is a bug...
Same as your guys broken carousel and group buttons... and calendar picker... Seriously!! I am not your guys personal debug boy... I have things to do and your guys software makes my work take longer...
Why on earth my company wants to you use your guys ridiculously expensive software baffles me. It's ridiculous... I even left a bad review and still nothing... No response to my feedback or the broken issues.

Why!!! must I scroll endlessly looking for an element that I just pasted.
Why can't you paste it in my screen of view... 
why??? Must I go searching!!! for pasted elements...
Why doesn't your stuff work!!! and why must I constantly find a fix...
Your stuff does not work!!! and I am getting more and more frustrated the more I have to use your guys stuff!!! 

You guys charge an arm and a leg for your software and it doesn't even work properly... What a joke of a company you guys are... I am sick of your broken stuff!!!

I started on OutSystems 10 and you guys stated you would not fix anything in OutSystems 10 because it was been deprecated. So we upgraded to 11 and everything was still broken... honestly you guys are a joke... and a waste of my time. My patience has run out now!!!

For over a year now you guys have still not fixed these issues.

At what point are you guys actually going to show some pride in your work...

When i paste something, i always open the widget tree and right click on the parent element where i want something to be pasted into, then i press paste and it gets added to that element. Maybe this helps:



For the broken caroussel and group buttons, can you please give us some more information so we can help you determine a solution?

Bas de Jong wrote:

When i paste something, i always open the widget tree and right click on the parent element where i want something to be pasted into, then i press paste and it gets added to that element. Maybe this helps:



For the broken caroussel and group buttons, can you please give us some more information so we can help you determine a solution?

Hi thanks for the idea but no this will not work. I stated that it's with regards to logic.
There is no widget tree in the logic tab. So that won't help. I adjusted the post so you
can see it more clearly now. 


Solution

Hi Garth,

Yes, I find when I paste onto the action canvas the pasted element moves to the top left of the screen.  Is this the issue you are experiencing?

However, by right-clicking on the canvas and selecting paste, the pasted element appears near the location of the right-click.

I hope this helps.

Kind regards,

Stuart


Solution

@Stuart Harris
Thank you I have not tested your answer but I am sure it will work. Pretty straight forward solution you offered. good idea!

@Stuart Harris
With regards to the element going to the top left. Sometimes it does. Other times it will get pasted miles away from anything in my project. I'm fairly certain this is due to the size of my project. But none the less it's annoying. Apart from that when I connect my flow lines sometimes it will jump down or move my screen somewhere. And then I can't see my element and have to scroll around to find it. Once I've found it I must still drag it to where it should be. Then when I connect my flow lines it will jump my screen down or up or right or left and I must scroll back to my position so I can carry on... Every time I have to go searching for my stuff I just get angry. It's extremely infuriating!!! When I am trying to work and every time I do something my screen is jumped to who knows where...

Thanks God for this! I'm also experiencing this. The Ctrl+V way to paste faster but it's broken! Sometimes the pasted element jumps top left, sometimes top right, sometimes I don't even know where it jumps to.