Good evening, 

While using the Advanced Excel component from the Forge, we ran into an issue when trying to import an excel file into our application. 

We successfully use this component a lot, but we always call the actions Workbook_Open when exporting an Excel (on which we write values on) that we have within our resources as a template. 

We tried to call the action Workbook_Open while importing an Excel file that is not stored as a resource in Outsystems. And it gives the error message :

Access path 'c:\windows\system32\inetsrv\"fileName" denied.

We also tried to store this imported file first in our database before calling the action, but it gives the same message. 

Did someone had the same issue ? 

Thanks in advance !

Sylvian 

Solution

Ok we found out:

The action Workbook_Open tries EITHER to open the file thanks to his FileName, OR with the Binary. 

As we tried to do both as the same time, the error was showing. 

In order to make it more clear for anyone who run into this, hereby a screenshot of the code where we discovered our problem. 

Solution