Hi All,

We recently upgraded our outsystems version and found two new roles in lifetime, "Create Applications" and "Add References to System". 

Noticed that the default administrator role does not have these two roles checked by default for our installation and we can't enable it, but we can do a workaround by creating a new role and setting everything on. 

Any idea if this is intended, or an issue due to the upgrade?


Hi caulibean,


I think this is due to diffrence between the role of company adminstrator and infrastructure adminstrator. 


Please refere the link below to read about them in brief.
https://success.outsystems.com/Support/Enterprise_Customers/OutSystems_Support/Managing_Your_Company_Permissions_on_outsystems.com


Regards,

Vaibhav

vaibhav shukla wrote:

Hi caulibean,


I think this is due to diffrence between the role of company adminstrator and infrastructure adminstrator. 


Please refere the link below to read about them in brief.
https://success.outsystems.com/Support/Enterprise_Customers/OutSystems_Support/Managing_Your_Company_Permissions_on_outsystems.com


Regards,

Vaibhav

Hi Vaibhav, 

Need to add that mine is an on-premise setup. 

I'm just curious whether it was intended by OutSystems that the Administrator Role doesn't have rights to these two settings for security measures, or if its just a bug due to the upgrade. 


Hi Caulibean,

I don't think its a bug as these create application and add reference feature for a company administrator seems of less use. Think of it on a giant company with a lot of individual involved in a product building. 


Hope this helps

Vaibhav