68
Views
4
Comments
Solved
Table in table: "cannot read property 'setAttribute' of undefined'
Question

I'm trying to develop screen which should show a table in a table. I know that I have to create a webblock for the second table. Although the data is shown correctly on the screen an error message is show "cannot read property 'setAttribute' of undefined". I already did some trial and error and the error comes as soon as I add the table to the webblock. If I just set a text in the webblock the error doesn't show.


I have added the OML, in case someone would like to try. Any help appreciated!



Regards,

John.

PMPlanboard.oml

mvp_badge
MVP
Rank: #72
Solution

Just an FYI, this bug has been fixed in Platform Server version 11.10.0 or later.

  • Fixed "Cannot read property 'setAttribute' of undefined" error when creating nested tables with Table Records widget in Reactive Web App. (RTAF-2995)

Regards,

Nordin

Rank: #374

Hi, friend!

Send the .OML and a print of the screen error, please!


Best Regards

Rank: #2211

Lenon Manhães wrote:

Hi, friend!

Send the .OML and a print of the screen error, please!


Best Regards

The OML was sent in the first post?


Rank: #27102

Hello


I am facing the same issue : a table containing a block that contains a table

if the table header is set to true, we got this error Cannot read property 'setAttribute' of undefined 

if the block is outside the table, there is no error

Thanks for your help

mvp_badge
MVP
Rank: #72
Solution

Just an FYI, this bug has been fixed in Platform Server version 11.10.0 or later.

  • Fixed "Cannot read property 'setAttribute' of undefined" error when creating nested tables with Table Records widget in Reactive Web App. (RTAF-2995)

Regards,

Nordin