Compilation Error after adding SOAP Consume

I am trying to consume an EOD (ATT) SOAP WSDL, when I add any of the items and try to publish I get the error below:

Internal Error
Compilation Error.
Global.asax.cs(122,22): error CS0117: 'ssDEV_EODapi_IS.File' does not contain a definition for 'Exists'
            if (File.Exists(assemblyToLoad)) {


State: Second stage compilation


   at OutSystems.HubEdition.ServerCommon.MessageBrokers.ErrorLoggingMessageBroker.#RCb(IMessageObject message)
   at OutSystems.HubEdition.ServerCommon.MessageBrokers.ErrorLoggingMessageBroker.ReportMessage(IEnumerable`1 messages)
   at #b2b.#t3b.InnerExecute(IEnumerable`1& result)
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask`3.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask`3.Run(InputType context, IMessageBroker messageBroker, OutputType& result)
   at #b2b.#m3b.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.ServerCommon.Tasks.TaskRunner.Run()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at #b2b.#b3b.#uo.#88b()
   at OutSystems.HubEdition.ServerCommon.Tasks.TaskRunner.Run()
   at #b2b.#b3b.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.DeploymentController.Compiler.<>c__DisplayClass154_0.<PublishOml>b__0()
   at OutSystems.HubEdition.DeploymentController.Compiler.PublishOml(Object publishContext)
   at #xSb.#2wb.#UQ.#vFb(Object s)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()


This is a brand new service module with zero added references.

And this is the WSDL I am trying to consume:

https://api-simmanagement.att.com/Webservice_Sim_V3/Webservice_sim.asmx?wsdl

Hi Nicholas,

To me it looks like ambiguity in the keywords as you can see it says " 'ssDEV_EODapi_IS.File' does not contain a definition for 'Exists'" and in if condition you have File.Exists check.

This File.Exists supposed to refer System.IO but looks like it is conflicting with ssDEV_EODapi_IS.File.