[Html2PdfConverter] Error generating PDF - Warning: SSL error ignored


 Version platform: 10.0.1021.0 ;
 Version Service Studio: 10.0.1022.0 ;
 Web application;
 
I am getting the error bellow with the html2pdfconverter on our TST Environment but it works on DEV.

This error happens when I invoke the GeneratePDF action.

[>                                                           ] 0%
[======>                                                     ] 10%
Warning: SSL error ignored                                        
[=================>                                          ] 29%
[===================>                                        ] 32%
Warning: SSL error ignored                                        
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
[======================>                                     ] 37%
[=========================>                                  ] 42%
[===========================>                                ] 45%
[============================>                               ] 47%
[=======================================>                    ] 65%
[================================================>           ] 80%
[===================================================>        ] 86%
[============================================================] 100%
Counting pages (2/6)                                              
[============================================================] Object 1 of 1
Resolving links (4/6)                                                      
[============================================================] Object 1 of 1
Loading headers and footers (5/6)                                          
[>                                                           ] 0%
[>                                                           ] 1%
[>                                                           ] 1%
[=>                                                          ] 2%
[=>                                                          ] 2%
[=>                                                          ] 3%
[=>                                                          ] 3%
[==>                                                         ] 4%
[===>                                                        ] 5%
[===>                                                        ] 5%
[===>                                                        ] 6%
[===>                                                        ] 6%
[====>                                                       ] 7%
[====>                                                       ] 7%
[====>                                                       ] 8%
[====>                                                       ] 8%
[=====>                                                      ] 9%
[======>                                                     ] 10%
Warning: SSL error ignored                                        
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored
Warning: SSL error ignored


I uploaded the binaries related with the version 0.12.5 - Windows - MSVC 2015 - win64 for the both environments.


Notes:

  1. I was already using this component in all environments but for documents without header and footer ,and it is working.
  2. I had the need to add Footer and Header to the OtherArgs input. It is working in DEV but in TST it gives the error described above. Additionally, I did a small test to remove the OtherArgs in TST and the Document was successfully generated without Header and Footer. So it looks like the problem is here.
  3. I did the test of invoking the DEV urls (Main Page, Header, Footer) to generate the PDF in a TST environment, and it works.
  4. I have already configured the call with HTTP and HTTPS by changing the HTTP Security settings on the page. I made changes to the page that downloads, and the pages (Main Page, Header, Footer) that result in the PDF. Did not work.


The problem started to happen when I added Header and Footer to OtherArgs, I've been with this situation for too long and honestly, I don't know what I'm doing wrong. Can anyone help me with this situation?

Thanks in advance,

Tiago Mateus