Cannot update user related entity

I'm working on Service studio 11, on a mobile app. No error message.

Here is my issue:

I have created a simple data model with a 1-1 relationship of a boolean entity with my users:


My users can register on my app. So I have created a sign up form, where users input simple details and are able to set that "YesNo" entity to a value (True or False):

The button "Register" includes the whole form.

In the following flow, "get yesno for update" is set with UserId, and CreateOrUpdateYesNo is set as such:

Now what happens when User registers:

- User information is updated in the DB

- User logs in correcly

- YesNo entity is NOT updated, no matter what


Can someone help me find out why YesNo entity is not updated?


Thank you very much.

Hi,

I was a little confused by your code. You have a get before an apdate. What is the reason?

Can you send the OML?

Nuno Miguel Verdasca wrote:

Hi,

I was a little confused by your code. You have a get before an apdate. What is the reason?

Can you send the OML?

Hi, sure here it is. Thank you for looking.

I can't test it because I lack a module from you. But either way, try to do this! If not, send the other module


Apologies for the silly entity name. Frustration... :)

The module thing is strange, as I haven't added any. Here's a new version, I have removed all the unused dependencies...

I have tried your solution but it doesn't work either.

Hi,

now I understand what your problem is. It never updates, because you have the Id of that table as the ID of the USER, what happens, as there is no user, it will record the first entry with ID = 0, and then you will never be able to update. What I advise you ... You register the user, and when you have a user ID, then you grab that ID and pass the ID in the assign.


See if you understand, and if you don't tell me, that I am trying to help you among my things that I have to do.

Dammit, that's 100% clear, thank you!

Hi again, I've tried that second screen thing, no matter what I do (I've tried several things), I can't seem to get that YesNo entity updated... 

Let me check Nicola

Can you give this module?



Solution

Hi,
Some points:
- The table must be as Exponse Read Only -> NO
- Being the Id itself, it must be AutoNumber -> Yes




Solution

Thank you, this was the issue !

Also, I updated the flow on the second screen to this :

The app says that this is exposing me to security issues, so data validation on server side will be necessary in the future.

Many thanks for your help ! This wrecked my brain for much longer than I can admit.