I'm developing a product that has a centralized services app, a mobile app, and a website.

In my services app, I'm bootstrapping some example users and entities to help the development. The problem is that I cannot log in with the user credentials on the mobile app.

When I create an aggregate for users in the mobile app I can see the users I've bootstrapped in the services app

But when I try to log in to the mobile app, it says I've got the wrong credentials

I tried looking into the Users app. There are zero users associated with the mobile application, and the services application does not appear at all on the list. I think this is a bit weird, could it be related to the problem?


I've added the services app as a dependency on the mobile app. What else am I missing? Thanks.

PS: I have edited the screen captures only to remove any sensitive information such as product names

Solution

Hi Daniel,

Did you encrypt the password when bootstrapping the users? As i see it in plain text in your aggregateI do think that is wat goes wrong.

https://success.outsystems.com/Documentation/11/Reference/OutSystems_APIs/Users_API#EncryptPassword

Regards,

Daniel


Solution

Hi Daniel H, 

Can you see the bootstrapped users in the Users module? Did you use the provided actions to create the users or did you create the User entities yourself via the database actions?

You need to use the User_Create action from the Users module. 


And not the CreateUser from the User Entity


Daniel and Vincent,

Thank you so much. Both of the approaches worked perfectly :)