Hi All,


https://www.outsystems.com/forge/Component_Reviews.aspx?ProjectId=1421

I was trying to implement the Amazon SQS connection for sending message to the Queue but was getting this error 

"Credential should be scopedto a valid region, not 'vpce' "

Don't know what the issue is . The region entered was right . Any help will be appreciated .


Thanks

Pranav 

Hi Pranav,

Did you check the link on the Amazon_Region site property for instructions?


Regards,

Daniel

Hi Pranav,

The definition of the credentials used to connect to AWS are done inside the "GetAmazonCredentials" server action.

This function uses either the data sent in the "AWSCredentials" input of the Message_SEnd action or, if that isn't defined, the site properties values that are defined inside the SQLConnector module.

Can you clarify what values are you passing in the AWSCredentials input and the value that you have in the site properties?

Hi Daniël Kuhlmann & Carlos Sousa, thanks for your reply.


Hi  Daniël Kuhlmann

I checked there is no site property or input parameter that is accepting Amazon_Region. Instead, the input parameter name is ServiceURL and the site property contains Amazon_SQSUrl.

Hi Carlos Sousa,

Yes, I have checked that function and I have also updated the site property with my value. still, I am getting the same error.



Hi Pranav,

You are right, I am mistaken with another AWS component.

The URL value for the AWS sqs service I used for testing is: https://sqs.us-east-1.amazonaws.com and it should match the region in which you activated the service in the AWS console, for me it was us-east-1.

Regards,

Daniel




Hi Daniël Kuhlmann & Carlos Sousa,

Thank you very much for your help. The problem was not with the connector. I even tried creating my own integration to test but was getting the same error.

The problem was on the server-side, The DevOps team did some modification on the Host file and now it started working.

Link for reference :https://www.howtogeek.com/howto/27350/beginner-geek-how-to-edit-your-hosts-file/


Thanks :)

Good to know it's now working. Keep up the good work