Can someone help with this error ?!!

Invalid object name 'hubstate.ASPStateTempSessionsExtVars'.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Invalid object name 'hubstate.ASPStateTempSessionsExtVars'.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

I'm able to open ServiceCenter but when i try to open another APP i get that error....

any ideia ? 
in service center the error is :

[1] Unable to connect to SQL Server session database.

at OutSystems.HubEdition.RuntimePlatform.SessionState.SqlSessionStateStore.ThrowSqlConnectionException(IDbConnection conn, Exception e)
at OutSystems.HubEdition.RuntimePlatform.SessionState.SqlSessionStateStore.HandleInsertException(IDbConnection conn, Exception e, Boolean newItem, String id)
at OutSystems.HubEdition.RuntimePlatform.SessionState.SqlSessionStateStore.CreateUninitializedItem(HttpContext context, String id, Int32 timeout)
at System.Web.SessionState.SessionStateModule.CreateUninitializedSessionState()
at System.Web.SessionState.SessionStateModule.GetSessionStateItem()
at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
at System.Web.HttpApplication.AsyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Any Idea ?
Hi Bruno.

I regret noticing that you are facing so many bumps in your development process, but we're all here to help the best we can.

At first sight I would say that this has something to do with the Session database configuration... What I could suggest immediately is for you to restart the SQL service in the database service, and see if it helps, though I suspect it might not.

I'm assuming, though, that the installation of your Platform Server has gone well, so what I can ask for now is:

- Does this happen in all your applications, or only in some specific? I'm not counting with Service Center, which you already said it worked.
- If it's only in specific applications, have these applications been republished after you have last upgraded your Platform Server? Does it have an exclamantion mark or a red cross besides it in Service Center?
- What version of the Platform are you using? Is it the latest version? In case it is a bug, this problem might already have been fixed in more recent versions.
- Is your server fruit of an upgraded 4.xx version, or is it a clean 5.x install?

Let us know about this, in order for us to be able to better contact you. Have you sent this issue to OutSystems' support department?

Best regards, and good work.

Paulo Tavares

hello Paulo,

is a fresh installation of version 4.2. I set up an environment to make some minor corrections to some client applications.
and therefore I am using a community license for version 4.2.

To throw some situations that you recorded:
I  already restarted the SQL service;
Repeat the steps for the Configuration Tool;
It happens in all applications except Servicecenter;
The database is clean, has published a solution after the installation so no need to re-publish. There are no broken references.

However I doubt a small part, I'm using a windows XP for this test. Is it a problem?
Anyway I will try in 2003 to see if this is the problem

Best Regards
Bruno Rebelo
Hi Bruno,

It seem that your Database Session model may have some inconsistencies. I would suggest that you change the name of the Sessions Catalog in the Configuration Tool and reconfigure the Session Database, you will need your SQL administrator login and password to do this.

Please let me know how it goes.

Best regards,
Renato Gonçalves
Im also with the same problem when I try to access service studio. I-ve only installed enterprise manager and, after this, I got this error.

Any clue
Hi Carlos

The error Bruno is having is a runtime error when accessing the application, i.e. when accessing the server. It is not a problem with Service Studio.
Can you detail what error you get and what you do to obtain it - maybe I can be of assistance?


Did you solve your problems?

Best regards,
Renato Gonçalves

I have a similar problem... 
In Outsystems Configuration Tool, tab Session i've put ASPState in Catalog and it works.

Best Regards,

I had a similar issue with my community edition.

I noticed that the problem was due to the fact that I had a dbo.ASPStateTempSessionsExtVars table in the Session Catalog instead of a hubstate.ASPStateTempSessionsExtVars. I deleted the Session Catalog, created an new empty one and reran the OutSystems configuration tool and it worked - the  hubstate.ASPStateTempSessionsExtVars table was created.

Could it be that you have the same issue - having the dbo.ASPStateTempSessionsExtVars table in the Session Catalog?


Daniel Lourenço

I resolved my problem by creating a new schema in the database.
That's because when I created the OSASPState  went to the configuration tool in order to create this table and they all had been created as dbo.ASPState ...........

Solved this way:

After creating the Schema OSSTATE (which was intending)
ran this query in sql :


CREATE TABLE [OSState].[ASPStateTempSessionsExtVars](
[SessionId] [varchar](50) COLLATE Latin1_General_CI_AI NOT NULL,
[Variable] [varchar](100) COLLATE Latin1_General_CI_AI NOT NULL,
[DataShort] [varbinary](7000) NULL,
[DataLong] [image] NULL DEFAULT (NULL)


i hope it help someone else.

Best Regards

I had this issue with the new 5.1 version, for some reason i had a dbo.ASPStateTempSessionsExtVars instead of the hubstate.ASPStateTempSessionsExtVars.

I executed the "Configure Schema Database" on the configuration tool several times and it didn't work, so I just created a schema named hubstate in the ASPState database and used the following command:

ALTER SCHEMA hubstate TRANSFER dbo.ASPStateTempSessionsExtVars;

After this I executed once more the "Configure Schema Database" and it's working properly now (hopefully ;)).

What was the weird thing in all of this is that the Service Center was working properly for some time (a couple of hours), and then ceased to work unexpectedly.

Hope it helps.

Best regards,