Agile Platform default port 80


I'm new in OutSystems and i'm installing the Agile Platform, and i have two questions:

1 - There are a way to configure the SQL Instance used by OutSystems, without be by "Configuration Tool" after the installation?

2 - Agile Platform use by default the 80 port! How can we change the port when other application uses that port?

Thanks for advance

Hi Nuno, and welcome to the OutSystems forums!

I have two questions for you, that might help us answer yours:

- Why would you need to configure the SQL instance used by OutSystems, without being through the Configuration Tool? That is, what specific requirement do you have that can't be done by opening the configuration tool to configure the SQL instance when you need to do so? Usually, if you're trying to change something in the Agile Platform configuration, it has to be done through that tool. If you're trying to do some specific change SQL Server related, you can try to do it in the SQL Server Management console, but you might end up changing something that will have bad results.

- In terms of the port 80 configuration, the Agile Platform uses that port by default - the standard port for HTTP connections - because it is the default port of IIS, the Microsoft web server, and we generally recommend that other applications change their settings. That should usually be possible, unless you are running two servers in your computer and would need the original one to keep port 80. One application that usually needs to be changed is Skype, in the Advanced > Connection menu. Can't the other application's port be changed?

If you are still adamant in changing the Agile Platform port, let us know.

Best regards,

Paulo Tavares

Hi Paulo,

Thank you for the quickness given to my questions.

About question 1.

What's the criteria to OutSystems usage instance on the installation? Because OutSystems don't create a new Instance, ok? It use an existing instance in the installation? We can in the Configuration Tool manipulate the "active" instance, but suppose you create an instance specific to install OutSystems.
The only way to use is, install OutSystms in a "random" instance and after instalation finish go to "Configuration Tool" and configure the rigth instance!
Is this the correct way to do this?

About question2

I have CollabNet Subversion  in a machine that uses specific 80 port!
OutSystems always use the port or can we manipulate them to specific cases?

Best regards,

Nuno Barroso

Hi Nuno.

So you do have two servers running on your machine :) Let's see what we can do about it then. From searching google, what I'd recommend being the "easier" way out for now is to change CollabNet's Apache server default to 8080 instead of 80. I know I'm just focusing on "changing the other application's port", but it might be the most straightforward solution for now.

[Edit:] Sorry, I had a link that could be useful, about running CollabNet's Apache and IIS simultaneously.

Regarding the instance, OutSystems will create a new instance in the SQL server you have running. If you already have SQL Server installed, I'm pretty sure that it will use the one you already have, and create a new database catalog there. Why would you want to setup OutSystems in an existing instance, may I ask? If you want to access the data in existing instances from OutSystems applications, the easiest way to do it is through Integration Studio, there's a wizard that does it in seconds. You can keep your existing instances isolated from the OutSystems one.

I hope I'm not making much of a confusion trying to clear this up. Let me know if this helps, or how can we help you further!

Best regards,

Paulo Tavares


For now you Win ;)

I will change the CollabNet's Apache server port.
This is a test machine, so i don't have problems on change it. But you understand my question, if in a "real environment", that situation appear, i need to know how to solve it.

That was a good help,

Thank you.

Best regards,
Nuno Barroso

Hi Nuno!

Glad to know it somehow helped - I know that it wasn't the solution you were looking for.

You are right; you're in a test machine, so that can be done. In a production environment, that would have had to be dealt with differently, of course.

Let us know how your experience goes!

Best regards,

Paulo Tavares
Hi Nuno,

although I haven't tried yet changing the SQL port used by outsystems wich I think is port 1521
This is from the hsconf configuration file
if you want to change it, I'd say you could test this by saving your configuration file, then, edit the document with notepad, change the port, in import the file. also you'd need make sure that your SQL server is configured to use that new port.

about IIS, you can yet IIS to use anyport really. Just make sure that when you use servicestudio that you enter the port in the string you want to connect to.
for example localhost:81

I've tested this on Outsystems V5 works like a charm.
Hi Louis

That's not exactly true. :)

The server.hsconf configuration holds default settings for both supported RDBMS engines: SQL Server and Oracle. The DBPort 1521 you see, refers to the Oracle Port, and not the SQL Server. By default, when only specifying a server's name only on the Configuration Tool, the .NET Data Provider for SQL Server will attempt the SQL Server default port 1433. If you specify the server's name and instance name (hostname\instance), then the .NET Data Provider for SQL Server will attempt to search for that instance name (using SQL Server Browser services), which will then resolve to the current ip and port of that specific instance.

In the case of the Agile Platform Community Edition, the default SQL Server installation will use a named instance approach, "(local)\OUTSYSTEMS", and thus, it doesn't use default port 1433, normally.

Regarding the IIS configuration to listen to port 81, yes it's possible, but you'll need to guarantee that it keeps listening to port 80 on localhost IP address, otherwise, several features of the Agile Platform won't work, including: timers, SMSs, Deployment ping(s) and Service Center monitoring.


Miguel Simões João