Resource Adding or selecting crashes

Resource Adding or selecting crashes

  
Hi,

Adding or just selecting a resource on a oml file crashes the 5.0.2.6 community edition service center.

Is this a problem of this particular version? If so, how can I download a previous version? I've searched your site and have not found a reference to previous builds :\

Thanks
Hi José!

Welcome to the OutSystems forums.

I'm sure that's not supposed to happen, so what I am going to suggest is:

- If Service Studio's "Submit Error Report" window shows up, send the eSpace and a description of the problem to the support team, since they'll probably be better able to handle it there, being a crash.
- If it doesn't (or even if you have already submitted it to the support team), send the eSpace you're trying to access as well as external resources (if necessary), and let us know which resource are you selecting or trying to add in order for us to try and replicate the problem here.

[Edit] I was able to replicate it once, but the second time around it did not crash at all...

Could you describe a bit better what you're trying to accomplish? Maybe we can help you around it for the time being.

Best regards,

Paulo Tavares
Hi Paulo, thanks for the prompt reply.

I was trying to create a new Web Block for use on other eSpaces using javascript resources. That's when the crashes first started. I submitted  the crash report and when I went to check if I had done something wrong by opening the fusioncharts espace, it also crashed just by selecting the resources. Also sent the error report but I wanted to keep on with the development of the block. If this was a problem only with this version of the service studio, i would download and install a previous one.

thanks

[Edit] - Mine crashes all the time :(
Hi José.

Let's try and get you through the development of the block, then.

Since mine doesn't crash - at least so far - could you attach the eSpace, and the resource file(s) you're trying to add to it to your post? You may need to compress them all to a single .zip file.

Send them over, and I'll see if I can try to add the resources and send them back to you!

Best regards,

Paulo Tavares
Here is the file Paulo

When I open the oml it automatically crashes. The only thing it has is 2 resources.

Thanks
Hi José.

Indeed, the same thing happened to me. I was, however, able to add all the resource files to the eSpace in a previous version.

See if this way, even though it shows a warning as it opens, you can keep on working.

If not, I recommend you let us know so that we can try to figure something out in between.

We usually remove the links to previous versions in order to have people always working on the latest build. The problem seems to be that, with so many things related to resources and multi-language support done for 5.0.2.6, something must have gone wrong.

Let us know how it all turns out - and good luck with your project.

Best regards,

Paulo Tavares
Hi Paulo!

Thanks for the commitment. Indeed I can open it and it gives a crash as it opens. If I save with the webscreen selected it won't give that opening error. I had to change some directories on some of those resources but every try is a "fail" giving 2 consecutive errors and closing.

It would be easier and less painfull for you if you could give me a link to a previous version install that does not have this bug.

Thanks again
Hi José.

It is indeed possible for us to provide you with a previous version of Service Studio.

However, for that to happen, you must contact our technical support directly. I recommend you explicitely mention that we talked anout this, refer this forum topic to them, and say that you need Service Studio 5.0.2.3 . They'll then provide you a private link for you to download it.

I hope this allows you to proceed. Sorry for the inconvenience.

Let me know if this works, or if you need anything else.

Best regards,

Paulo Tavares