Last element in a list is set to null when i append new element

I have a employee structure

and i have a local variable which is list of employees

when i append to this list in an popup then i tried to append to it again all the last element attributes are set to null values, and the enw element is appended successfully 

Hey Muhamed Akl,

Would you mind uploading an example OML that shows the issue?  I would be happy to help, but I need more information.

Sorry but it is not a personal environment so i can't share it with you , tell me the info you need and i'll provide it

Can you either recreate a example in a personal environment, or post some screenshots of the related flows and relevant properties?

Hi Muhamed,

Make sure that you do not ListAppend the Current of a List to itself. This goes wrong. Always use a seperate Variable.

Kilian Hekhuis wrote:

Hi Muhamed,

Make sure that you do not ListAppend the Current of a List to itself. This goes wrong. Always use a seperate Variable.

I'm not doing that I'm appending an element of a list to another list


Muhamed Akl wrote:

Kilian Hekhuis wrote:

Hi Muhamed,

Make sure that you do not ListAppend the Current of a List to itself. This goes wrong. Always use a seperate Variable.

I'm not doing that I'm appending an element of a list to another list


I've broken this into two steps by assigning the inserted element to an variable then inserting it to the list instead of assigning an element in a list directly and the problem still occurs