No process definition exists with key

Hi 

Does anyone here encountered/experienced this kind of error? Basically, i am running a simple process and this error happens.

Regards,
Froi

Hi Froi,

I have extensively worked with BPT but never encountered with this error, Did you try republishing your espace.

If it is possible, can you please share the oml, so that I can have a look.


Thanks,

Sachin

Hi Sachin,

Yes I published the espace while there is an active instance of the process. Is that the reason why I encountered this error?

Thank you for your response.

Regards,
Froi


 

Froilan Benito wrote:

Hi Sachin,

Yes I published the espace while there is an active instance of the process. Is that the reason why I encountered this error?

Thank you for your response.

Regards,
Froi


 

Hi Froi,

Are you receiving this error every time when you are running a process? Or you received it while you were publishing the espace ?

Since when you upgrade the process in service studio then the success of these upgrades depends on both the kind of changes you made to the process flow and the current execution state of process instances.

Thanks,

Sachin



Solution

Below is the link of the document which briefs about the impact analysis when we upgrade the process.

https://success.outsystems.com/Documentation/11/Developing_an_Application/Use_Processes_(BPT)/Upgrade_Processes

Thanks,

Sachin

Solution

Hi Sachin,

The process is pretty much working. This is just the first time I've encountered such error. 


Sachin Mahawar wrote:

Below is the link of the document which briefs about the impact analysis when we upgrade the process.

https://success.outsystems.com/Documentation/11/Developing_an_Application/Use_Processes_(BPT)/Upgrade_Processes

Thanks,

Sachin

This is very useful. Thank you very much.