Component installation problem

Hi!

I have installed two versions of Outsystems, 10 and 11. Whenever I try to install something from forge, I can't install anything in version 11, either directly from the forge or the file I downloaded, it is always version 10 that is evoked. Can someone help please.

thanks


Carlos Messias

Hi Carlos,

Try to one thing -

Open Outsystem service studio 11 and after click on environment Tab and open downloaded oml or oap  file from here

IN this place you can open.

Regards

Rahul Sahu

Solution

Are you trying to install by double clicking the file you download from forge? and The open in service studio option on forge as alternate option. Right? 

When you have two versions installed there are two options to install the component to any specific version otherwise file will be opened in one defaut installed service studio version.

1. You can download the OML/ OAP from forge and then open you service studio of the version where you want to install the fore component. Use Environment -> open files option and select the file you have download. Make sure that you are connected to the environment where you want to install it :)

2. Alternatively open the service studio where you want to open component go to the OutSystems tab (see below in image) and search and install component from here.

Solution

Yes, the best way to do it is as Nikhil shows.


Within the serivce studio you go to the window that he indicates, and from there you go to fetch the components of the forge for that platform, whereas when you go directly to the website, it is not guaranteed that he knows which of the versions of the platforms is intended.

Nikhil Gaur wrote:

Are you trying to install by double clicking the file you download from forge? and The open in service studio option on forge as alternate option. Right? 

When you have two versions installed there are two options to install the component to any specific version otherwise file will be opened in one defaut installed service studio version.

1. You can download the OML/ OAP from forge and then open you service studio of the version where you want to install the fore component. Use Environment -> open files option and select the file you have download. Make sure that you are connected to the environment where you want to install it :)

2. Alternatively open the service studio where you want to open component go to the OutSystems tab (see below in image) and search and install component from here.

Thanks you all. It's working fine.