While trying to open the Phone Style Guide after download from Silk UI Mobile, it prompts for missing dependencies update and post update there are 12 errors getting displayed. Snippet attached.

Has anyone experienced it and any solution that you can share?

Response is appreciated!

Anand Jayaraman wrote:

While trying to open the Phone Style Guide after download from Silk UI Mobile, it prompts for missing dependencies update and post update there are 12 errors getting displayed. Snippet attached.

Has anyone experienced it and any solution that you can share?

Response is appreciated!

Could you please share error screen shot rather than warning,so that we can look into it


Hi Anand,

This is because OutSystems has its new UI framework called OutSystems UI. So when you downloaded the application it had silk UI depedencies. After updating depedencies some of the blocks that you are using are removed and that is why you are getting error.

But I think you can easily overcome this problem as there are alternate / similar block available in OutSystems UI. See below screenshot and you will notice you just need to change it in your app and you are good to go.

Hi Anand Jayaraman,

The other option that i see is  you can still use the Silk UI pattern with Outsystems 11 , you just need to install the SilkUi dependency in your environment and the  patter will be available to you. However it will be good if you make changes in application according to the OutsystemsUI framework so that you can leverage the new UI framework.


Regards,

-PJ-



Salman Ansari wrote:

Anand Jayaraman wrote:

While trying to open the Phone Style Guide after download from Silk UI Mobile, it prompts for missing dependencies update and post update there are 12 errors getting displayed. Snippet attached.

Has anyone experienced it and any solution that you can share?

Response is appreciated!

Could you please share error screen shot rather than warning,so that we can look into it




Anand Jayaraman wrote:

While trying to open the Phone Style Guide after download from Silk UI Mobile, it prompts for missing dependencies update and post update there are 12 errors getting displayed. Snippet attached.

Has anyone experienced it and any solution that you can share?

Response is appreciated!


Hi Anand, do you need a style guide for mobile, need to be Silk UI? if yes check the error an upload, install, reference the missing modules.

If not use the NEw Outsystems UI and check this mobile style guide: https://www.outsystems.com/forge/component-overview/8241/outsystems-ui-mobile-style-guide-template