Error in Email Campaign

Error in Email Campaign

  
Hello
I get this error when a try start campaign, someone cam help me.
 
Thanks


&quot;Timer StartCampaign error (inside action &#39;SendBulkEmails&#39;). Timer duration = 2 secs:Non-negative number required.<br />
Parameter name: count [retry 3 of 3 scheduled] <br />
Stack: System.ArgumentOutOfRangeException: Non-negative number required.<br />
Parameter name: count<br />
at ssEmailCampaignManager.RssExtensionRichMail.MssRichMailCreate(HeContext heContext, String inParamFrom, String inParamTo, String inParamCc, String inParamBcc, String inParamContentType, String inParamCharset, String inParamSubject, String inParamBody, Boolean inParamBodyIsHtml, String inParamUrl, Boolean inParamInlineImages, String inParamInReplyTo, String&amp; outParamBoundary, String&amp; outParamMail)<br />
at ssEmailCampaignManager.Actions.ActionRichMailCreate(HeContext heContext, String inParamFrom, String inParamTo, String inParamCc, String inParamBcc, String inParamContentType, String inParamCharset, String inParamSubject, String inParamBody, Boolean inParamBodyIsHtml, String inParamUrl, Boolean inParamInlineImages, String inParamInReplyTo, String&amp; outParamBoundary, String&amp; outParamMail)<br />
at ssEmailCampaignManager.Actions.ActionSendEmail(HeContext heContext, Int32 inParamCampaignListId, String inParamEmailTo, String inParamEmailPage, String inParamEmailFrom, String inParamSubject, String inParamTargetURL)<br />
at ssEmailCampaignManager.Actions.ActionSendBulkEmails(HeContext heContext)<br />
at ssEmailCampaignManager.TimerStartCampaign.Execute(HeContext heContext, Int32 timeout)<br />
-Env-<br />
eSpaceVer: 7 (Id=130, PubId=106, CompiledWith=5.0.2.7)<br />
RequestUrl: http://localhost/EmailCampaignManager/_TimerHandler.asmx<br />
AppDomain: /LM/W3SVC/1/ROOT/EmailCampaignManager-14-129139518037332262<br />
Path: C:\...\PS\running\EmailCampaignManager.559128491\<br />
Locale: en-US<br />
DateFormat: yyyy-MM-dd<br />
PID: 6956 (&#39;w3wp&#39;, Started=&#39;25-03-2010 00:12:34&#39;, Priv=329Mb, Virt=2935Mb)<br />
TID: 16<br />
.NET: 2.0.50727.4927 <br />
Hi Victor,

I do not know which might be the cause of the error, but I suspect it could be somehow related with the structure of the Web Page used to sent the campaign.
Have you tried sending a campaign with another page and see if it works?
Do you have other errors occuring before this one in the error log?

Regards,

Daniel Lourenço
OutSystems
Hi Vitor,

It really looks like a bug of the RichMail extension.

I suggest to you submit feedback to the OutSystems Product Support (email to support@outsystems.com). Also you should also send the value of the input parameters of the 'RichMailCreate' action, it will be necessary to discover the problem.


Regards,
João Portela
Hello,
I'm start learning with the OutSystem is likely that this already committing any errors. The input parameter to the Email URL is: www.outsystems.com/agile_software/news.pasx.

Regards,

Vitor
Hi,

This URL (www.outsystems.com/agile_software/news.pasx) or this (www.outsystems.com/agile_software/news.aspx) are being redirectedf to OutSystems main page (www.outsystems.com). is this right?

I'm assuming that you're using the eMail Campaing Manager available in the TechCenter\Components section. If this is the case, there's an audit in the action that is throwing the error with the information of the URL that is being fetch and sent to RichMail.CreateEmail. Can you get this information?

regards,
João Portela
Vitor, why don't you create a simple email screen and use it to send your campaign? The OutSystems homepage will probably not be a good page to send by email (it is not designed to be read in an email client). This might also be the reason why you're getting this error - The RichMail action may not be able to create an email based on this screen.

Create a simple email screen in an application of yours and try sending your campaign with that screen. Tell me the result (and also what João asked above - which is the URL that is printed in your General Log? Remember that if you are using a community edition, the General Log will not be available).

Regards,

Daniel Lourenço
OutSystems