[CKEditor.Reactive] [CKEditor React] Cannot set property 'ckEditorUpdate' of undefined  TypeError
Question
Forge component by Fábio Fantato Rodrigues

Hi all, 

I try to put the ckeditor on my reactive web application but the follow error message always popup.



Here is my CKEditor Property

Hi Parko,

You can do 2 thinks to solve it. First, you need to use the textarea instead of input text. The CKEditor doesn't work well with input. And put your CKeditor inside a IF associate to yours Get....IsDataFetched.

This will guarantee you only have you editor loaded after the data and DOM are available.


Best regards

Fabio

Hi Fabio, 

Thanks for your comment! To give more information, in above situation i have already used Textarea with the Editor. 


And furthermore, I would like to ask what do you mean by "put your CKeditor inside a IF associate to yours Get....IsDataFetched." ? 


Thank you very much for your time.


Best regards,

Parko

Parko Cham wrote:

Hi Fabio, 

Thanks for your comment! To give more information, in above situation i have already used Textarea with the Editor. 


And furthermore, I would like to ask what do you mean by "put your CKeditor inside a IF associate to yours Get....IsDataFetched." ? 


Thank you very much for your time.


Best regards,

Parko


Follow up:

The flow of problem occur. I have a "Screen1" with a CKEditor, and "Screen2" have a button with only destination to "Screen1". 

The CKEditor work fine whenever I go to "Screen1" for the first time. After go back to "Screen2" and click to "Screen1". The Above error occur.


I have the same problem. It could be due to OutsystemsUI update? Because with this last version and with the other versions of CK Editor the error appear. This error didn't appear in the past.

Hi Alvaro,

Can you share the error that you are getting in your console, as well as the steps to reproduce it in our side ?

Thanks!

Hi,

With the error the CK doesn't render in the screen.

Thanks Alvaro.

Its possible to you to send me the .oml to try replicate in my side ?

Hello, I've found the solution. The problem is the location of the widget. The CKEditor block must be after the TextArea widget to avoid this problem.

Regards.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.