User_GetUnifiedLogoutURL Error - No SAML Support on Platform

Hi,

Our environments are set up as follows:

  • Dev - Cloud Hosted
  • QA - Cloud Hosted
  • Prod - On Prem (Azure)

The problem is that the Production environment has Azure AD enabled, so I am busy updating my Flows to accommodate the redirect... I'm using this link:

https://success.outsystems.com/Support/Enterprise_Customers/Upgrading/Updating_the_login%2F%2Flogout_flows_of_your_Reactive_Web_App_to_support_SAML_2.0

My cloud hosted Dev and QA environments are obviously not making use of SAML or Azure AD, so now the referenced User_GetUnifiedLogoutURL function is stopping me from building my solution, because those Cloud environments are not SAML enabled.

The error I get is this

Thank you

Rudi

Hi Rudi,

Do your environments meet the following pre-requisites as mentioned in the article?

Also, make sure you have the latest version of Service Studio and OutSystems UI Templates Reactive installed.

Hope this helps.

Regards,

Nordin

Nordin Ahdi wrote:

Hi Rudi,

Do your environments meet the following pre-requisites as mentioned in the article?

Also, make sure you have the latest version of Service Studio and OutSystems UI Templates Reactive installed.

Hope this helps.

Regards,

Nordin

Sometimes I'm just plain blind... I see I'm not environment Version 11.0.614.0, I just assumed since it's hosted, the latest will be there.

Thanks


No problem Rudi :). 

This document explains the steps in order to request a Platform upgrade of your OutSystems Cloud environments. You need to open a support case with OutSystems Support for that.

And since you have a hybrid infrastructure, make sure to read this part too.

Regards,

Nordin