Losing session variable in IE

Losing session variable in IE

  
Hello,
I am having difficulties in keeping a value of a session variable. The strange thing is that in firefox i do not lose that value it only happens in internet explorer. Let me see if I can explain the context;

I have a screen that uses the value of the session to identify the contents that were associated in that session. In the same screen i have a link that opens a pop up that allows the user to preview the content which he associated. What happens is after I close the pop up, and return to the screen where the user can associate more contents, the session variable is incremented (+1).
i already clean the cache of IE..

Best regards,
A.R.
Hi António

The fact that works in Firefox, but not in the IE, is in fact an odd pattern. However it's possible that the implementation you're doing, could depend somehow of the web browser, if you use javascript or other client side content to update the session variable.

Can you replicate the same problem with a simple espace (that doesn't reference any other)? If so, upload it to the forums, so we can take a look at the pattern, and hopefully help you with it.

Cheers

Miguel Simões João
I have the same kind of issue. Loosing session vars in Chrome when opening a Popup.
It looks like its starting a complete new session and kills the current one.
The reason might be because the popup is actually an iFrame with a complete HTML document

I'll try this one out with a simple OML and upload it here

Hope somebody can fix this !!
wrote:
I have the same kind of issue. Loosing session vars in Chrome when opening a Popup.
It looks like its starting a complete new session and kills the current one.
The reason might be because the popup is actually an iFrame with a complete HTML document

I'll try this one out with a simple OML and upload it here

Hope somebody can fix this !!
 
 Hi Joop

The problem you are having is not related to sessions - the problem is that the "open-popup" button is not saving the value you write in the input. This is actually expected, since the button is of type Navigate, and Navigate does not save values.

Please check the attached sample for clarification.

With best regards,