[OutSystems UI] [bug ] tab inside a popup shows all tab content

Forge Component
(84)
Published on 1 Jun (4 days ago) by OutSystems R&D
84 votes
Published on 1 Jun (4 days ago) by OutSystems R&D

OutSystems v11

OutSystems UI 2.4.2

the Tab pattern works fine on a page. However, placing inside a popup is not working. It ignores the TabHeader and shows all TabContentItem.


Hi George,


I can't reproduce this, works fine here.  This is reactive, right ?  Can you share an oml or show some screen shots of your design, like a fully expanded widget tree to see what it is exactly you are doing.


See attached oml, to compare what you are doing.


Dorine

Dorine Boudry wrote:

Hi George,


I can't reproduce this, works fine here.  This is reactive, right ?  Can you share an oml or show some screen shots of your design, like a fully expanded widget tree to see what it is exactly you are doing.


See attached oml, to compare what you are doing.


Dorine


Hi Dorine,


I test your oml file and have the issue in my dev environment. It shows all tab contents, as shown below:


I'm on OutSystems UI 2.4.2 and OS platform 11.8.0 (Build 12006)


Regards,

George

Ok,

that's interesting, my personal environment is on platform 11.7.4 (build17634), so just to exclude any other reasons, can you put anonymous access on both screens and reimplement and give link to your version, here's a link to mine.


EDIT :  the reason is not the platform version, but the Outsystems UI version, I just upgraded to version 2.4.2, and now I have the same problem as you.  I implemented a clone of my module after the upgrade, and it shows the same problem.

Dorine

Hi Dorine,


Thanks for the confirmation that it is a bug in OutSystems UI 2.4.2. 

Regards,

George