IDE slow when working with a page with many web blocks

Hi.

I have specific pages that contain many web blocks. These blocks are quite nested. The IDE becomes incredibly slow. Even for the slightest adjustment to anything. I've ringfenced them in IF statements and then adjust them so it shows the branch where the block is not in so the IDE don't have to render it. This has worked but certain modules are still extremely slow.

Any advice?

Thank you.

Hello.

That slowness usually means the page is too crowded. I had it in two situations:

-one page with the entire site that toggles content with JS (don't judge me, it was before Reactive, Mobile or even Offline).

-one table with several layers of WebBlocks inside WebBlocks that created around 300 elements visible on screen.


If you can't remove elements, that trick with IFs is the quickest way. But I have a ticket open with Support regarding that, so if I get a better alternative I can share it.

JP Brits wrote:

Hi.

I have specific pages that contain many web blocks. These blocks are quite nested. The IDE becomes incredibly slow. Even for the slightest adjustment to anything. I've ringfenced them in IF statements and then adjust them so it shows the branch where the block is not in so the IDE don't have to render it. This has worked but certain modules are still extremely slow.

Any advice?

Thank you.

Hi JP,

Did you look into these suggestions from silimar topics


https://www.outsystems.com/forums/discussion/50720/service-studio-10-very-slow/

https://www.outsystems.com/forums/discussion/18114/service-studio-screen-render-issues/


Thanks

Ravi