67
Views
9
Comments
Solved
[Ultimate PDF] I can't print with an invalid SSL certificate
Question
Forge component by Leonardo Fernandes
15
Published on 08 Jan 2021

Hi guys,

I'm trying to generate a PDF on an environment with SSL certificate issues and facing net::ERR_CERT_COMMON_NAME_INVALID error.

any URL without certificate issues is working fine.

Is there any bypass to this issue?


mvp_badge
MVP
Rank: #5
Solution

Hi Anderson. Could you check if version 2.0.2 fixes your issues?

Thanks.

mvp_badge
MVP
Rank: #161

Look it obvious but I have to ask... Did you try to replace https to http?

Rank: #22991

Hi Leandro,

<edit>

yes I tried, same error.

I realized that I only experimented with the demo module or relative URL in my code.

Using the HTTPRequestHandler > MakeAbsoluteURL action to build the URL worked fine.

</edit>

btw, using the demo module, when I tried the url with IP (http://127.0.0.1/ ),I got this validation message:

Rank: #22991

about the SSL certificate issue, I found this link, might be helpful.

https://stackoverflow.com/questions/45510973/headless-chrome-ignore-certificate-errors

mvp_badge
MVP
Rank: #5
Solution

Hi Anderson. Could you check if version 2.0.2 fixes your issues?

Thanks.

Rank: #22991

Hi Leonardo,

the demo is working fine, but the SSL certificate issue persists.

mvp_badge
MVP
Rank: #5

Hi Anderson. Is your SSL certificate valid? If it's not valid, then the component is behaving as expected.

With the newer version, you can use http to render a screen. There was some code in the previous version that was forcing https, but not anymore.

Rank: #22991

Hi Leonardo,

yes, the certificate is valid, but not for one specific URL we use to do a few tests.

mvp_badge
MVP
Rank: #5

Can you use http for your tests?

Rank: #22991

it's not ideal, but yes I can.