Hi, 

we want to present the OS Live Demo for a Health Application. We cannot follow the instructions step by step as suggested from OutSystems. We create a phone app. And a phone module. 

The live demo adds a Screen with the template "onboarding full color". This is not possible anymore. The use of the template "account portal" is not possible either. For both templates we get the warning

While we want to use the provided OutSystems templates this is rather upsetting. 

https://www.outsystems.com/OutSystemsUIWebsite/ScreenDetail?PatternId=101 doesn't even state the used template anymore.

About a month ago these templates still worked on our development environment, which I used to write a walkthrough. But know they seem to be incompatible too.

Are there any fast means to fix this? I think we had an update of our environment to the latest OutSystems version, but I think it won't be possible to roll back those changes.

I managed to drill it down to:

versus

I need the OSUIMobilePhone theme....How can I get that back?

Hi Philipp,

This happens when the environment is ungraded for the platform version however the required components aren't. To summarize, probably not everything is in sync. I would suggest to check following 2 forge components first and get their latest versions installed and see if you get proper templates available:

  1. OutSystems UI
  2. OutSystems UI Templates Mobile  

I managed to fix it part way by adding the dependency to the mentioned themes and changing the base theme for the application theme.

Then I need to update the color theme to have the color of the screens like I want them. But wehn I use the full Color onboarding now, this is what is shown in the browser:

I can switch the theme back and it will load, but this is unsatisfying for a live demo that should demonstrate how easy to handle OS is.

Akshay Puri wrote:

Hi Philipp,

This happens when the environment is ungraded for the platform version however the required components aren't. To summarize, probably not everything is in sync. I would suggest to check following 2 forge components first and get their latest versions installed and see if you get proper templates available:

  1. OutSystems UI
  2. OutSystems UI Templates Mobile  

I did check them, but updating doesn't give the required result. Problem is: The live demo requires the use of the onboarding full color template to look good. If we cannot use that we need to adjust the provided images etc. etc.

I tried updating OutSystems Now since that is the component, that is responsible for previewing in the browser like I understand, but here is the problem that our platform vesion doesn't support the current OS Now Version and I would "force the install".