[Camera Plugin] Barcode and Camera - Android Manifest error

Forge Component
(36)
Published on 16 Apr by OutSystems R&D
36 votes
Published on 16 Apr by OutSystems R&D

Hi Colleagues,

as you know there are plugins that when we put them together, without doing any workaround, they can give an error in Android Manifest, because they are using the same feature of the mobile device

I intend to use the Barcode Plugin and the Camera Plugin, and as such it's giving me the error "duplicate elements declared in androidmanifest" when I generate the APK.

Does anyone have any idea of a workaround for this?

Do you know if there is a version on github that has this problem solved without I having to do a fork and edit the plugin.xml file?

Cheers,

Miguel

Solution

Hello everyone, as I solved the problem, I thought it best to leave the solution here.

In fact it's necessary to fork the github of the OutSystems component. If you have this need and this problem in the future, you can go to the Extensibility Configurations of the Barcode Plugin, and change the URL that is there for this one: "https://github.com/miguelverdasca/csZBar-1.git#v1_1.0"

This has only one problem, it's if the OutSystems team makes updates to the plugin you won't receive them, but when that happens, it's a matter of making a new fork, and changing the code of the first image to that of the second image.




Thanks all,

Regards,
Miguel

Solution