Issue when uploading OSP file in Service Center

I have OSP file with size 280 MB. I can't able to upload this big file in Service Center. If am uploading small size file, then its uploaded. But I want to upload this big file without splitting. Anybody know the solution for this, kindly update me.



regards,

Naveen

Hi Naveen,

By default, Service Center has a timeout when you try to upload a file.

My first suggestion is that you split that OSP file in smaller pieces (looking at the dependencies and including the bottom layers first).


If you really need to upload an entire OSP file with that size, you need to change some config files in the server. I had this situation in the past and we needed to change values in the applicationHost.config and machine.config files.


Please check this post with a possible solution for your scenario. But this implies to change config files in the server machine which is not recommended. I would try to split it in 2 solutions before this approach.


Kind regards,

Rui Barradas

Rui Barradas wrote:

Hi Naveen,

By default, Service Center has a timeout when you try to upload a file.

My first suggestion is that you split that OSP file in smaller pieces (looking at the dependencies and including the bottom layers first).


If you really need to upload an entire OSP file with that size, you need to change some config files in the server. I had this situation in the past and we needed to change values in the applicationHost.config and machine.config files.


Please check this post with a possible solution for your scenario. But this implies to change config files in the server machine which is not recommended. I would try to split it in 2 solutions before this approach.


Kind regards,

Rui Barradas

Hi Rui Barradas,

                 Thanks for the Solution. I followed this post and found these 2 files in my system. Exactly where I need to add this lines.


regards,

Naveen

Hi Naveen,

The lines should already be there in the applicationHost.config and machine.config files. Just use the Search function (CTRL + F) to look for the parameters.

You would only need to modify the values accordingly.

Regards,

Nordin

Nordin Ahdi wrote:

Hi Naveen,

The lines should already be there in the applicationHost.config and machine.config files. Just use the Search function (CTRL + F) to look for the parameters.

You would only need to modify the values accordingly.

Regards,

Nordin


Hi Nordin,

                I searched the parameters, its not there. Thats why replied.


regards,

Naveen

some settings are not explicitly configured in your configs if default values are not overridden . Just add your parameters explicitly in the required sections and it should work. 


Cheers

Hi Naveen,

In that case, whoever installed the OutSystems Platform on your server must have overlooked the Tuning and Security Checklist part of the Installation Checklist. It is labeled as a required step.


Anyway, you can go ahead and follow the steps mentioned above in order to add the required lines.

Hope this helps!

Regards,

Nordin

Hi Naveen,

These lines should be in the files with its default values.

Like Nordin said, they are part of the Tuning and Security Section during the Platform Server installation and they should be visible in these config files.

Try to search for executionTimeout and maxAllowedContentLength.


Kind regards,

Rui Barradas