Consumed SOAP Service getting a Structure as arrayoflist as datatype

Hi Team,

Am trying to Consume a SOAP service on my web application module using WSDL, which i have consumed and worked properly before Outsystems up-gradation from Version 10 to 11.

Due to Up-graduation its started throwing 403 error, based on Outsystems suggestion, tried to re-consume the service, but this time am getting a new structure as arrayofDocstoreProperty. and it is one of the input parameter data type for the service. In Old we have DocstoreProperty List as a data type.

verified with service provider, to confirm any change made in WSDL, but they confirmed no change made form there end.

Kindly anyone suggest how to change the datatype of input parameter.


Regards,

Manikandan K


Hi Manikandan,

In OS11 the implementation of SOAP has changed, this can in certain use cases cause a WSDL successfully imported in OS10, to cause problems in OS11.

To read more about the changes see:

For unsupported use cases see:

https://success.outsystems.com/Documentation/11/Extensibility_and_Integration/SOAP/Consuming_SOAP_Web_Services/Unsupported_SOAP_Use_Cases

Regards,

Daniel