New to Outsystems, problem with RichWidget and HTTPRequest extensions

New to Outsystems, problem with RichWidget and HTTPRequest extensions

  

I keep getting the following errors when trying to run the applications downloaded from outsystems:
'GetPageName' Action is incompatible with the 'HTTPRequestHandler' extension definition. Please update it.
I have the exact same problem with the RichWidgetExtension

Using v. 5.0.2.14
Hi John,

It should be a inconsistent (broken) reference, i.e., one of the applications (eSpaces) you’re running should have been linked with a modified version of that action ('GetPageName' Action of extension 'HTTPRequestHandler').
 
There are several ways you can fix this problem:
  • Go to service center (http://localhost/servicecenter/), discover the espace with the broken references, download the espace with Service Studio and fix the reference.
  • You can also publish the solution where’s the espace with the broken reference. The publication of the solution should refresh (fix) the reference.
 
Please let me know if you understand how to fix it.
 
By the way, you’re having problems with which application? If you downloaded it from the Network, we can war the owner to fix the reference so next time someone downloaded it he/she has no problems.
 
Regards,
João Portela
Not John, but I run into the same issue as him though. I'm doing the last 'getting started' scenario (Recruitment) and without doing anything, except publishing it, I can't login.

Will try out your suggestions, but as you were asking about the location of the error, I'd figured I would let you know.
Hi Jos,

Still having problem logging into your application?

just a reminder: the default admin password is 'admin'.

regards,
João Portela
Hi João,

The issue did remain, but I've upgraded and not yet checked to see if it still occurs. It wasn't as much a login issue but more an outdated references issue. I tried to publish the HTTPRequestHandler again, but that didn't change anything. I downloaded the latest version of it, published it, and then updated the Recruitment scenario, but it it still showed as outdated in Service Center, and error'd out with the same error message as before.

I thought that if you, after publishing an extension, update an eSpace that uses that extension it on publishing should be updated. This didn't seem to be the case.

Will see if the issue still exists, but it should be easily replicatable as I only downloaded the 'suite' and started with the scenarios.
Hi Jos,

If you can replicate the problem easily, please attach the espace and extension (if possible) and let me know which Agile Platform version you're using.


Regards,
João Portela
Hi Joao,

I have tried to upgrade one application that developed by outsystem version 6 to version 7 . when i try to publish the application i am getting error like " Missing Reference " for  HTTPRequestHandler , Text , RichMail , RichWidget . 

how can i fix this issue. is that possible to download from outsystem?

Thanks in advance,
Prassin
Hi Prassin,

Those components are all distributed with the platform.
Make sure you installed the "System Components" solution, following the instructions from the installation checklist.

Regards,
João Rosado