I have been trying to figure this out for three days.  I am trying to use a combo box that will show supplier names.  I have an entity Suppliers that have two attributes.  SupplierID and SupplierName.

Here is my setup

When I run the app the box does not populate.

What am I doing wrong?

Hi,

before all, you're working on Traditional Web or React/Mobile?


You could create a simple structure with just one integer attribute and then use a list of that structure as the source for the combobox. Please, look to this video.


Cheers

It is a traditional web app. Does it need to be a static entity?

Hwllo Andrew,

Di you check that the entity OutSupplierList has records on the database?

Hello Andrew,

Please check the entity OutSupplierList  has records. Otherwise it should yield the results.

Plenty of data. The table has about 300 records

Andrew Finkelstein wrote:

Plenty of data. The table has about 300 records

can u upload the .oml file to have a look.


Andrew Finkelstein wrote:

I have been trying to figure this out for three days.  I am trying to use a combo box that will show supplier names.  I have an entity Suppliers that have two attributes.  SupplierID and SupplierName.

Here is my setup

When I run the app the box does not populate.

What am I doing wrong?


Hi,


use integer variable instead of aggregate and check.


thanks

Here you go

Andrew Finkelstein wrote:

Here you go

Hi Andrew , 

Your Outsupplierlist which is coming from a external DB has some missing references. Please update the references and try again. Also if you are using the SelectSupplier Dropdown inside the form attach it with a form variable or use a local variable with Outsupplierlist Identifier type as part of best practices. Please try these and let me know.


Hello Andrew, 

In which screen, you are trying to do the Combobox? I can't find it in your code.

Also, did you follow this guide?

https://success.outsystems.com/Documentation/11/Extensibility_and_Integration/Integrate_with_an_External_Database

Andrew Finkelstein wrote:

Here you go



I have changed the local variable to an identifier.  Still no luck:(  If I try it with a static entity I have no issues.

All DB connections are set and working correctly.  I am stumped

Hello Andrew, 

In which screen, you are trying to do the Combobox? I can't find it in your code (That you send before)

Yeah , please add the comboBox (I guess that will be in the DisplayBooking page) and update the dependencies and share the oml file. Couldn't publish last time due to dependency errors. 

Luís Cardoso wrote:

Hello Andrew, 

In which screen, you are trying to do the Combobox? I can't find it in your code (That you send before)

It is on the DisplayBookings Page


Thank you for all your help.  The situation has miraculously taken care of it self 

Thanks. I can see it now.

In the page OutSupplierLists, you can see the list of the records?

Hi!


Glad to know. I saw it that you change the variable here. I think that maybe this is your first problem.


Andrew Finkelstein wrote:

Thank you for all your help.  The situation has miraculously taken care of it self