Can't debug eSpace

Can't debug eSpace

  
Hi.

I can't debug my eSpace's, nothing happens (the execution doesn't jump to Service Studio).
I'm always getting this error on Service Center:


O ficheiro '/Teste/_debuggerEvents.ashx' não existe.

em System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)
em System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
em System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
em System.Web.UI.SimpleHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)
em System.Web.UI.SimpleHandlerFactory.GetHandler(HttpContext context, String requestType, String virtualPath, String path)
em System.Web.HttpApplication.MaterializeHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
em System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
-Env-
eSpaceVer: 4 (Id=192, PubId=247, CompiledWith=5.0.2.14)
RequestUrl: http://10.0.0.7/Teste/_debuggerEvents.ashx?debugSessionToken=9517860d-4519-4fb9-a3d8-9b1b8dda17fc&lastEventReceived=0&eSpaceUID=n6WkrnoQ6k+lKftEToeHtA
AppDomain: /LM/W3SVC/1/ROOT/Teste-31-129183242623500000
Path: C:\...\PS\running\Teste.10486521\
Locale: pt-PT
DateFormat: yyyy-MM-dd
PID: 7256 ('w3wp', Started='14-05-2010 10:03:06', Priv=299Mb, Virt=5541Mb)
TID: 9
.NET: 2.0.50727.4200


I'm using Service Studio 5.0.2.12, running  from a laptop with Windows Vista Business 32bit. The platform server is in a development machine with Windows Server 2008 Standard x64.
The firewall in the development machine is disabled..
Hi Carlos.

The error you describe seems to be related to the server environment, albeit there not being much information available. More than a firewall issue, it would seem that either IIS or the ASP.Net framework are having some difficulties in handling/managing the debug request - either because the application hasn't been allowed to create the required files (or hasn't created them because of a bug from OutSystems' end), or doesn't have the permissions to access them.

Have you submitted this problem to our support department? They will probably be better able to ask you for specific information regarding the server environment you're running, and be better able to track down the problem.

I'll ask you to share the solution with us, if you manage to work around it - I imagine this will be showing up to more people.

Regards,

Paulo Tavares
Hi Carlos,

The problem you describe appears to be the creating of PTAs (the admin subdirectory) virtual directories on the wrong application pool. One way to solved this is to manually change the application pool from DefaultAppPool to OutSystemsApplications for each PTA. Or you can change on the default Web Site, and force the change on all sub-directories. New PTAs should be created correctly, so this should only need to be done once.

Can you try this procedure and let us know if it solved your problem?

Best regards,
Renato Gonçalves
They are already on OutSystemsApplications application pool.
I have only one application running on DefaultAppPool, but it's not from the OutSystems platform.
Hi Carlos,

Can you access your test application URL plus /_ping.aspx (http://10.0.0.7/Teste/_ping.aspx)?
And the admin personal area (http://10.0.0.7/Teste/admin/_ping.aspx)?

If you where able to access this pages can you try debugging again?

Best regards,
Renato Gonçalves