Unable to call SOAP web service from OutSystems...

Hi, I'm using OutSystems 11 cloud platform and trying to consume a SOAP web service from my web/mobile app. I'm getting the attached error when invoking SOAP method. Is there any clue what's going on.


I have tested the same SOAP web service from outside of OutSystems using tools like Postman and I was able to call successfully and got the response. The only thing I had to set was the Content-Type header to "text/xml" to make it work in Postman.

Hallo Khurram

if i look at the error stack this is more a server error than a content error.

is the url correct?

Hi Khurram,

The message is that the service is not available at the given endpoint. Check your effective endpoint configuration for your SOAP Service in the OutSystems environment using Service Studio.

https://success.outsystems.com/Documentation/11/Extensibility_and_Integration/SOAP/Consuming_SOAP_Web_Services/Configure_a_SOAP_Web_Service_at_Runtime

Regards,

Daniel

Hi Khurram,

Looks like a connectivity problem, are you sure the URL is reachable by the OutSystems server? 


Best Regards,

Leandro.

Thanks for the replies.


SOAP Web service that I'm consuming are available on cloud and tested them successfully in Postman from my development machine. So no issue with URL I believe.


It does seem to be a valid point if SOAP Web Service server is accessible from OutSystems or no. I'm using OutSystems 11 cloud environment. How can I make sure that OutSystems environment can reach SOAP Web Service server?

"So no issue with URL I believe."

Not in Postman, I agree, but that doesn't mean you cannot have an issue in OutSystems (maybe you made typo), maybe the effective URL was changed by someone else, I don't know but you better check the effective URL in service studio to exclude the possibility that that is causing the problem.

The https://itservices.imamu.edu.sa/outsystem/api.asmx?wsdl is indeed a valid endpoint reachable over the internet.

Do you get the same error message continuously every time you test? As the error message in your screenshot does suggest that it could be a temporary problem ad that you should try accessing the service again later.

I consumed the SOAP service myself and get the same error message.

Does this SOAP service maybe require a certificate?

Also, you could check if the firewall in the SOAP service machine is blocking incoming requests

Regards,

Daniel


Yes, I get the same error every time.


Noticed one thing. I consumed the web service by providing https://itservices.imamu.edu.sa/outsystem/api.asmx?wsdl URL in Service Studio. But in Service Center, URL endpoint is with http and not https (http://itservices.imamu.edu.sa/outsystem/api.asmx). I tried to change the Effective URL to https but did not succeed. Another error appeared.

No certificate is required as per the documentation from consumer. I don't think of firewall blocking incoming requests on SOAP service machine because I successfully invoked the methods from Postman from my development machine.

Hi Khurram,

I don't know then what could be the cause of this problem. Let's hope someone else can help you.

Regards,

Daniel