When trying to download attachments i get the following error

When i download the file it returns 0 bytes but it dose create file


Hi Ryan,

We need a little more information in order to help you better.

  • What type of application are you developing (Traditional Web/Reactive Web/ Mobile)?
  • What kind of file are you trying to download?
  • Can you share a screenshot of your logic in the Download action?
  • Can you share a screenshot of the error?

It would be best if you could share a sample OML that replicates this behavior.

Thanks,

Nordin

Solution

Hi Ryan,

Nordin is right, you provide too little information, making it a guessing game what could be the problem.

My first thoughts would be to set a breakpoint on the download widget and check if the binary parameter I pass in actually has data. Maybe your aggregate is not retrieving a record (bad filter?) and you are passing the current record binary attribute (binary null) to it.

Regards,

Daniel

Solution

Nordin Ahdi wrote:

Hi Ryan,

We need a little more information in order to help you better.

  • What type of application are you developing (Traditional Web/Reactive Web/ Mobile)?
  • What kind of file are you trying to download?
  • Can you share a screenshot of your logic in the Download action?
  • Can you share a screenshot of the error?

It would be best if you could share a sample OML that replicates this behavior.

Thanks,

Nordin

Sorry about that, 


I am using reactive.

 i am downloading the file in the with the same extension it was uploaded wit. jpeg, pdf excl... 

my logic for the download i'm just getting a single record with the file name and the binary data



i will try re assigning the variables