Connecting to Amazon Instance

Connecting to Amazon Instance

Anybody had any problems connecting to the amazon instance from server studio through their corporate firewall. I have setup proxy server login under edit/preferences. Then File/Connect to server, entered the instance public DNS and selected connect.

I get "There was an error connecting <amazon public dns> host not found. I am guessing its a corporate firewall problem or my local PC has a problem.
Anybody had similar issues - what did you do to resolve?

I have tested this from my home installation and I have no problems.

Hi Eddie.

Welcome to the forums.

Indeed, at first sight it would seem that it is a firewall issue. I would suggest you test the connection using "ping" in the command line, and seeing if it goes through.

The best way to try and do it is also to involve your systems administrator.

On a side suggestion, you wouldn't be connected to a VPN when trying to connect to Amazon as well? Because that could be the reason why it wouldn't work.

Let us know if you're able to go around this.


Paulo Tavares
Hello Paulo,
I am not using VPN. I am using corporate network via my work PC.
I am also talking to my corporate security - I am bypassing the proxy file and pointing directly to the proxy server IP address.
There is a problem pinging an amazon Instance. On my home system I can log in to the amazon instance via service studio but I can't ping it.

Its frustrating to say the least.

Hi Eddie,

Can you access your <amazon public dns>/ServiceCenter from your home and work network?
Can you make a Telnet connection to your Amazon machine (from the command line type "telnet <amazon public dns> 80"), from your home and work network?

Best regards,
Renato Gonçalves
Hi Eddie

One tip: if you are not using the latest Service Studio revision ( try installing that one and see if it gets any better. You can see which Service Studio you are using under Help | About.

You can get Service Studio in TechCenter | Downloads, under Agile Platform -> Agile Platform 5.0.

If you look at the indications for this revision of Service Studio, you will see the following:
  • Improved Web-proxies communication (#134764)
Please reply if you get better results now.
I did have a problem on my home PC and what fixed that was upgrading to - on the home system everything is working - I can download apps and login to servicecenter. I am using windows 7 at home and for some reason telnet was not in my path when I tried it last night.

Work PC has been upgraded to service studio
result from telnet is:
H:\>telnet <amazon public DNS>
Connecting To <amazon public DNS>...Could not open connection to the host, on port 23: Connect failed
Still can't download apps either

As the home system is working on I am concentrating on finding out whats stopping the connection from my work PC. I think I should upgrade to when they both work.

Still having some issues here. I have had my proxy settings upgraded and I can now login to servicecenter from my work PC but getting service studio to login using the same login settings is proving unreliable. I get host not found most of the time. Is it time to upgrade service studio to as suggested earlier. I did stop and start my amazon instance to see if changing the public DNS would cause problems but its OK.

I have tried with the proxy settings in service studio and without.

Hi Eddie does fix problems specifically related to proxy server (I can tell you that it fixes some major problems) so I would suggest installing before spending any more time troubleshooting your problem.

You will not get any problems by switching your eSpaces between and, so you can do it with no concern.

My home PC is working with service studio
My work PC is now using service studio and the connection is working. I tested this by running the hello world tutorial.
This correctly displayed the output using the amazon public DNS in the url.

So Thankyou APN and everybody else for helping me sort this out.

Incidently I tried testing the connection with telnet but this failed with:

H:\>telnet <amzon public DNS> 80
Connecting To <amzon public DNS>...Could not open connection to the host, on port 80: Connect failed
In Service Studio there does not seem to be a way to tell if you are connected locally or to the amazon instance apart from when you try to publish - it might be a useful feature.
Hi Eddie,

I am extremely glad to know that you are now able to connect to your Amazon instance. Tell us if you have any other problems.

Regarding the connection status, you can use the Select Server functionality (see the image below)


Daniel Lourenço
I am not surprised that outsystems has already thought of this - I should have seen this but  thanks for highlighting this to me.