Reactive - List / Table - Unable to drag/drop identity attribute on list

Hi,

New to OS Reactive, so apologies in advance if this has been covered already (could not find in the forums)  


I seem to be having a problem with dragging my entity identifier item to the list? All other entity attributes can be dragged and dropped though....



External Extension (imported from MS SQL via integration studio)

OS Server: 11.8.1

Studio: (PC) 11.7.12 - 21963

All forge components/templates are current.


I can add this column manually and create it using an expression - would be nice to be able to drop them also :) 


Cheers, Mark




Hi Mark,

I could reproduce this behavior, and I agree that it doesn't make sense that it is not possible.

I will report it to OutSystems Reactive development team, I will keep you updated on their reply.

Regards,

Daniel

Hey Daniel,


Long time no see - yes, thanks for reporting that!


Cheers, Mark

Hi Mark,

Quick update, apparently this was previously already reported to, and analyzed by, the Reactive-Web team. 

When I get more news, I'll let you know.

Regards,

Daniel

Hi Daniel,

Thanks.

I have been out of the loop for quite some time regarding OS. Are OS Reactive applications really considered production-ready yet? I have been in Traditional web since OS 7.

Cheers, Mark


Hi Mark,

It depends on how you look at it. The Reactive Web app template and support by OutSystems is generally available, so production-ready. 

Does Reactive Web application template have all the features and possibilities you are used to with Traditional Web application template? No not (yet). For example, email templates, SEO rules, translations support are features on the roadmap of Reactive Web that are not delivered yet.

Regards,

Daniel