125
Views
6
Comments
Resource Not Versioned - Warning publishing
Question

Hi guys,


I am having an issue with a mobile application that we are building for a client.

When I publish a mobile module, I get the following error:


Resource Not Versioned             

The resource '/B2C_Invoice_IS/scripts/Extension.HttpsConsumer_Lib.model.js' of the producer module 'B2C_Invoice_IS' was not found in the application cache. Please republish 'B2C_Invoice_IS' to prevent runtime errors.


I have tried to republish a solution with full dependencies, all the modules, remove and re add the dependencies and nothing works.


Do you guys have any idea of what this could be?


Thanks in advance,

Cheers,

Gustavo

Rank: #2552

Hi,

Did you publish the solution with full compilations?

Best regards,

Ricardo Pisco.

Rank: #1097

Hi Ricardo,

Thanks a lot for your response!

Yes, that’s the second thing we tried after publishing the module and refreshing dependencies, no luck.

Rank: #225

Hi Gustavo,

I found below similar post on the forum with the problem you are facing, Can you try out the solution which is marked in the post.

https://www.outsystems.com/forums/discussion/34590/resource-not-versioned/

Thanks,

Sachin

 

Rank: #1097

Hello Sachin,


Yes, that was the first thing we tried and still with no luck!

Rank: #2552

Hi,

Looking at the solution presented by Sachin can you try this:


  1. Open B2C_Invoice_IS and hard refresh it (using service studio)
  2. Remove all references to B2C_Invoice_IS in the children module, publish ir and try opening the app to see if works
  3. Add the removed references to B2C_Invoice_IS and the code remove before if any (don't use a previous version of the module copy only the code)


Hope it helps.

Best regards,

Ricardo Pisco.

Rank: #144

Hi Gustavo,

I had the same situation in a project a couple months ago. I tried everything that I could (publish the modules by their specific layer order, publish a solution with all the modules, add/remove references, etc.). Unfortunately, none of those solved the issue for me.

Back in the days, I contacted OutSystems support and they told me that this warning doesn't affect the applications.

It is probably related with the caching mechanisms during the compilation of the modules, which is used to copy resources from the producer modules to the consumer modules.

You could verify this, but it involves to change system tables which is not recommended:

select * from ossys_Parameter where name like 'OutSystems.HubEdition.DisableCompilationCaches';
UPDATE ossys_Parameter SET VAL = 'True' where name like 'OutSystems.HubEdition.DisableCompilationCaches';

Then, restart the OutSystems Deployment Controller Service and try to publish again.


My suggestion is that you probably contact OutSystems support in order to get some assistance about this situation. Or you could just create a new module with the same code and the warning should disappear :)


Kind regards,

Rui Barradas