63
Views
2
Comments
[Custom Input Masks] Decimal input with comma Separator
Question
Forge component by Sara Gonçalves
46
Published on 23 Jul 2020

After upgrading from the Outsystems 10 to Outsystems 11, the CustomMask component is not working correctly when applying "Comma" as a Decimal Separator.
If you have a submit button to send data into the server, if the validation is "Client&Server" the infomation is sent wrong.
Example: "9,5" is received as "95"

I've created a test page were you can check that.

Other strange thing is, if you had values on the "Decimal Comma Separator Server Validation" and click on the "OK" of the "Decimal Comma Separator Client&Server Validation" it will change the "Decimal Comma Separator Server Validation" values



testv9.oml

Rank: #3365

João Réquio wrote:

After upgrading from the Outsystems 10 to Outsystems 11, the CustomMask component is not working correctly when applying "Comma" as a Decimal Separator.
If you have a submit button to send data into the server, if the validation is "Client&Server" the infomation is sent wrong.
Example: "9,5" is received as "95"

I've created a test page were you can check that.

Other strange thing is, if you had values on the "Decimal Comma Separator Server Validation" and click on the "OK" of the "Decimal Comma Separator Client&Server Validation" it will change the "Decimal Comma Separator Server Validation" values



 Hi,

I have the same problem. Did you already find a solution?

Kind regards,
Rik

 

Rank: #25273

I have the same issue , it is working with version 11.0.415.0 , but since version 11.0.503.100 , the comma seperator fails